Bug Hunting Session
Bug 121644 - Pressing on the "Reset" button when the writing focus is on the "Value" input field of a property causes LibreOffice to crash on Properties - Custom Properties
Summary: Pressing on the "Reset" button when the writing focus is on the "Value" input...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.4
Keywords: haveBacktrace
: 121643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-22 22:21 UTC by Liad Skiva
Modified: 2018-11-26 13:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["ListBox::GetSelectedEntryPos(long)"]


Attachments
gdb backtrace (15.54 KB, text/plain)
2018-11-22 22:59 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Liad Skiva 2018-11-22 22:21:21 UTC
Description:
Unsaved changes are not lost after crash

Steps to Reproduce:
1. Go to File->Properties.
2. Go to the "Custom Properties" tab.
3. Press the "Add Property" button.
4. Press on the "Value" input field of that property
5. Press the "Reset" button.

Actual Results:
When pressing the "Reset" button the property is being deleted and LibreOffice crashes.

Expected Results:
When pressing the "Reset" button the property should just get deleted without anything else happening.


Reproducible: Always


User Profile Reset: No



Additional Info:
- Pressing on the "Value" input field of an already existing (not new) property causes the same problem.
- The problem happens only when the chosen value on the "Type" field is Text or Number.

LibreOffice about info:
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: CL
Comment 1 Xisco Faulí 2018-11-22 22:54:10 UTC
Reproduced in

Version: 6.2.0.0.beta1+
Build ID: a5bb6a0406d0018d1df279b925c80b392d9db277
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e


LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

old crashes are still popping up
Comment 2 Xisco Faulí 2018-11-22 22:59:41 UTC
Created attachment 146926 [details]
gdb backtrace
Comment 3 Xisco Faulí 2018-11-22 23:00:11 UTC
@Caolán, I thought you might be interested in this crash...
Comment 4 Xisco Faulí 2018-11-22 23:11:55 UTC
*** Bug 121643 has been marked as a duplicate of this bug. ***
Comment 5 Caolán McNamara 2018-11-23 09:24:18 UTC
seems an easy fix
Comment 6 Xisco Faulí 2018-11-23 12:26:42 UTC
(In reply to Caolán McNamara from comment #5)
> seems an easy fix

Hi Caolán,
You think bug 121641 is easy to fix as well ? it's a problem in the same tab
Comment 7 Commit Notification 2018-11-23 12:59:33 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b3e5d954dccbac85c77d6096ea3be2b59d6288fd%5E%21

Resolves: tdf#121644 clear pointer to customlines when customlines cleared

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-11-23 20:28:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/10c6c35220c0c6e2c0aa7cdf146bff564da95eb7%5E%21

Resolves: tdf#121644 clear pointer to customlines when customlines cleared

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2018-11-23 20:31:21 UTC
backport to 6-1 in gerrit
Comment 10 Xisco Faulí 2018-11-26 13:14:38 UTC
Verified in

Version: 6.2.0.0.beta1+
Build ID: a63cd8bbe7cf881daa8dc7a7f32f3e5ac384e902
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this!!
Comment 11 Commit Notification 2018-11-26 13:39:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/0f59ab7aa00232a083f28a52d006b2ea361798e0%5E%21

Resolves: tdf#121644 clear pointer to customlines when customlines cleared

It will be available in 6.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.