Bug 121657 - FILEOPEN DOCX Automatic Hyphenate created with Word disappears
Summary: FILEOPEN DOCX Automatic Hyphenate created with Word disappears
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyphenation
  Show dependency treegraph
 
Reported: 2018-11-23 09:48 UTC by NISZ LibreOffice Team
Modified: 2019-10-17 09:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document side by side in Word and Writer. (214.58 KB, image/png)
2018-11-23 09:48 UTC, NISZ LibreOffice Team
Details
Example file from Word (20.19 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-23 09:49 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-11-23 09:48:07 UTC
Description:
Automatic Hyphenate in DOCX documents created with Microsoft Word 2010 disappears when the document is opened in LibreOffice Writer.

Steps to Reproduce:
1. Create a new document in Microsoft Word.
2. Type “=rand(2)” and press Enter.
3. On the Page Layout tab, in the Page Setup group, click Hyphenation.
4. Select Automatic.
5. Save the file as DOCX.
6. Open the same file in LibreOffice Writer.
7. Compare the original file opened in Word and Writer.

Actual Results:
Automatic Hyphenate disappears when the document is opened in LibreOffice Writer.

Expected Results:
Text should have the same Hyphenate as the original file when the document is 
opened in Microsoft Word 2010.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-11-23 09:48:43 UTC
Created attachment 146939 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2018-11-23 09:49:05 UTC
Created attachment 146940 [details]
Example file from Word
Comment 3 raal 2018-11-24 19:03:09 UTC
Confirm with Version: 6.2.0.0.beta1+
Build ID: 268364e35100b559f42d8c02b930c5cca1c84be7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
and 4.1
Comment 4 Samuel Mehrbrodt (allotropia) 2019-10-15 06:06:24 UTC
Hm this looks more like an issue with the dictionary (hyphenation info missing).

With German locale, everything works fine.

When I install this hungarian dictionary, hypenation also works: https://extensions.openoffice.org/en/project/hu_dicts
Comment 5 Samuel Mehrbrodt (allotropia) 2019-10-15 07:19:48 UTC
On Ubuntu, installing the package "hyphen-hu" fixes this for me.

On Windows, when selecting the Hungarian language support in the msi installer, hyphenation also works.

So this is not really a bug, but maybe the situation can be improved by informing the user about the missing dictionary/hypenation package.
Comment 6 NISZ LibreOffice Team 2019-10-15 07:31:35 UTC
Hi Samuel

Thanks for taking a look at this. It may very well the case that we made a mistake here and tested Hungarian hyphenation with SI-GUI nightly or bibisect builds, which apparently lack full localization support.

I checked the paragraph properties and indeed hyphenation is checked on Paragraph -> Text Flow.

Feel free to close this as NAB.
Comment 7 Commit Notification 2019-10-17 09:09:20 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c7c5f24f12c241cb72810abe596337e809138df0

tdf#121657 Show warning when no hyphenation info available for current lang

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Samuel Mehrbrodt (allotropia) 2019-10-17 09:11:36 UTC
So with above commit I added a warning when hyphenation can't be executed due to missing hyphenation info.
This could be expanded by putting a user visible warning in an infobar (see bug 128191).