Bug 121679 - Ctrl+Shift+J does not fully maximize the workspace on Ubuntu 18.10
Summary: Ctrl+Shift+J does not fully maximize the workspace on Ubuntu 18.10
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2018-11-23 15:44 UTC by Nikola Chikos
Modified: 2021-01-17 06:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot of LibreOffice in 'full-screen' mode with the OS's bar and the app's bar still showing. (62.75 KB, image/png)
2018-11-23 15:46 UTC, Nikola Chikos
Details
Blender full-screen appearance under Ubuntu 18.10 (167.69 KB, image/png)
2018-12-08 08:25 UTC, Nikola Chikos
Details
GIMP full-screen appearance under Ubuntu 18.10 (146.45 KB, image/png)
2018-12-08 08:26 UTC, Nikola Chikos
Details
Krita full-screen appearance under Ubuntu 18.10 (170.98 KB, image/png)
2018-12-08 08:26 UTC, Nikola Chikos
Details
A screenshot of LibreOffice in 'full-screen' mode with pixel-saver installed. (59.81 KB, image/png)
2019-01-17 08:07 UTC, Nikola Chikos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola Chikos 2018-11-23 15:44:18 UTC
Description:
Ctrl+Shift+J does not fully maximize the workspace on Ubuntu 18.10. I get two bars on top, the OS's standard bar and LibreOffice's bar. It could be a lot better if somehow I could eliminate those two bars and have just LibreOffice's menu bar instead. Apps such as GIMP, Inkscape, Krita, Darktable, Blender, etc. seem to apply full-screen mode better, at least in Ubuntu 18.10.

Steps to Reproduce:
1. Ctrl+Shift+J

Actual Results:
I get two bars on top, the OS's standard bar and LibreOffice's bar.

Expected Results:
Just the app's working space, whether that's a Writer document, a Calc table, etc.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Nikola Chikos 2018-11-23 15:46:24 UTC
Created attachment 146983 [details]
A screenshot of LibreOffice in 'full-screen' mode with the OS's bar and the app's bar still showing.
Comment 2 Durgapriyanka 2018-11-26 01:32:54 UTC
Can not reproduce in 

Version: 6.0.6.2
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 3 Nikola Chikos 2018-11-26 14:02:14 UTC
(In reply to Durgapriyanka from comment #2)
> Can not reproduce in 
> 
> Version: 6.0.6.2
> Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
> CPU threads: 2; OS: Windows 6.1; UI render: default; 
> Locale: en-US (en_US); Calc: group

Have you tried it in Ubuntu 18.10? Could you upload a screenshot? Thanks.
Comment 4 Fafa 2018-11-29 09:08:01 UTC
Bug not reproducible in version

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
Locale: zh-TW (zh_TW); UI-Language: en-US
Calc: threaded
Comment 5 Nikola Chikos 2018-11-29 09:16:51 UTC
(In reply to Fafa from comment #4)
> Bug not reproducible in version
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: 0f25a3c36f27fd51453b9a9115f236b83c143684
> CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-27_20:06:55
> Locale: zh-TW (zh_TW); UI-Language: en-US
> Calc: threaded

Calc maximizes just fine in Windows 10; it's not working properly in Ubuntu 18.10.
Comment 6 Vera 2018-12-07 22:02:02 UTC
(In reply to Nikola Chikos from comment #0)
> Description:
> Ctrl+Shift+J does not fully maximize the workspace on Ubuntu 18.10. I get
> two bars on top, the OS's standard bar and LibreOffice's bar. It could be a
> lot better if somehow I could eliminate those two bars and have just
> LibreOffice's menu bar instead. Apps such as GIMP, Inkscape, Krita,
> Darktable, Blender, etc. seem to apply full-screen mode better, at least in
> Ubuntu 18.10.

Could you provide a screenshot about a full-screen app which seems to have better appearance? I don't think so it's a LibreOffice issue.

According to your screenshot you're using Gnome desktop environment. Unity desktop environment has had the given feature.
Comment 7 Nikola Chikos 2018-12-08 08:25:28 UTC
Created attachment 147374 [details]
Blender full-screen appearance under Ubuntu 18.10
Comment 8 Nikola Chikos 2018-12-08 08:26:13 UTC
Created attachment 147375 [details]
GIMP full-screen appearance under Ubuntu 18.10
Comment 9 Nikola Chikos 2018-12-08 08:26:33 UTC
Created attachment 147376 [details]
Krita full-screen appearance under Ubuntu 18.10
Comment 10 Nikola Chikos 2018-12-08 08:27:29 UTC
(In reply to Vera from comment #6)
> (In reply to Nikola Chikos from comment #0)
> > Description:
> > Ctrl+Shift+J does not fully maximize the workspace on Ubuntu 18.10. I get
> > two bars on top, the OS's standard bar and LibreOffice's bar. It could be a
> > lot better if somehow I could eliminate those two bars and have just
> > LibreOffice's menu bar instead. Apps such as GIMP, Inkscape, Krita,
> > Darktable, Blender, etc. seem to apply full-screen mode better, at least in
> > Ubuntu 18.10.
> 
> Could you provide a screenshot about a full-screen app which seems to have
> better appearance? I don't think so it's a LibreOffice issue.
> 
> According to your screenshot you're using Gnome desktop environment. Unity
> desktop environment has had the given feature.

Hi, I've added Blender's, GIMP's and Krita's full-screen appearance modes under 18.10...
Comment 11 Vera 2018-12-09 14:37:03 UTC
Hi,

Oh, I see know.

I can confirm this issue in
Version: 6.3.0.0.alpha0+
Build ID: e4c2d0bb57ab8ea8f5c400d103d01376b8140f22
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-30_21:37:10
Locale: hu-HU (hu_HU.UTF-8); UI-Language: en-US
Calc: threaded

But only for Gnome desktop environment. Full screen feature is working properly in Unity and Xfce desktop environment.
Comment 12 Nikola Chikos 2018-12-09 15:10:06 UTC
Correct, but since Ubuntu is bound to use Gnome for some time now (I guess), it's a kind of a nuisance to lose that screen estate... :)
Comment 13 Vera 2018-12-09 15:16:38 UTC
Changing status to NEW
Comment 14 Xisco Faulí 2018-12-12 17:49:27 UTC Comment hidden (obsolete)
Comment 15 Nikola Chikos 2018-12-12 18:15:04 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2018-12-12 18:19:23 UTC
(In reply to Nikola Chikos from comment #15)
> (In reply to Xisco Faulí from comment #14)
> > Do you reproduce this behaviour if you launch libreoffice from commandline
> > like: SAL_USE_VCLPLUGIN=gtk soffice ?
> 
> Tried running by typing 'libreoffice SAL_USE_VCLPLUGIN=gtk soffice'. It says
> that neither gtk nor soffice can be found...

Sorry, wrong command. remove the first 'libreoffice'. just 'SAL_USE_VCLPLUGIN=gtk soffice' or 'SAL_USE_VCLPLUGIN=gtk libreoffice'
Comment 17 Nikola Chikos 2018-12-12 18:22:54 UTC
(In reply to Xisco Faulí from comment #16)
> (In reply to Nikola Chikos from comment #15)
> > (In reply to Xisco Faulí from comment #14)
> > > Do you reproduce this behaviour if you launch libreoffice from commandline
> > > like: SAL_USE_VCLPLUGIN=gtk soffice ?
> > 
> > Tried running by typing 'libreoffice SAL_USE_VCLPLUGIN=gtk soffice'. It says
> > that neither gtk nor soffice can be found...
> 
> Sorry, wrong command. remove the first 'libreoffice'. just
> 'SAL_USE_VCLPLUGIN=gtk soffice' or 'SAL_USE_VCLPLUGIN=gtk libreoffice'

Libreoffice launches, but there doesn't seem to have an impact on the full-screen mode...
Comment 18 Nikola Chikos 2019-01-17 08:06:35 UTC
Hey guys, just to let you know that I fixed the issue by installing pixel-saver as a GNOME extension. There's a single tab at the top, but I find this acceptable. Cheers!
Comment 19 Nikola Chikos 2019-01-17 08:07:15 UTC
Created attachment 148385 [details]
A screenshot of LibreOffice in 'full-screen' mode with pixel-saver installed.
Comment 20 QA Administrators 2021-01-17 04:12:12 UTC
Dear Nikola Chikos,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug