Bug 121691 - line callout doesn't draw in certain writer documents
Summary: line callout doesn't draw in certain writer documents
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2018-11-24 12:37 UTC by roumanet
Modified: 2018-12-12 18:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
which callout aren't working (4.03 KB, image/png)
2018-11-24 12:37 UTC, roumanet
Details
callout with yellow dot but no line (7.63 KB, image/png)
2018-11-24 12:38 UTC, roumanet
Details
Writer document where I can't use callout (lines not visible) (835.88 KB, application/vnd.oasis.opendocument.text)
2018-11-24 12:39 UTC, roumanet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2018-11-24 12:37:13 UTC
Created attachment 146994 [details]
which callout aren't working

On some documents only, I'm not able to visualize the line between endpoint and callcout box.
I've tried to modify properties (color, style, width, etc.) without success.

1. open the document
2. click on line callout (any of "line callout")
3. place de line callout : 2 yellow points are present to show where should be the line

However, "callouts" icon works fine (see attached picture)
Comment 1 roumanet 2018-11-24 12:38:30 UTC
Created attachment 146995 [details]
callout with yellow dot but no line
Comment 2 roumanet 2018-11-24 12:39:34 UTC
Created attachment 146996 [details]
Writer document where I can't use callout (lines not visible)
Comment 3 Regina Henschel 2018-11-24 16:37:52 UTC
I can reproduce the problem with your document in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 9e55c8c7ffc43004ca314edcd4712dcc29adf933
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

I cannot produce the problem with a new document.

It seems to be somehow connected to the TOC. If I delete the TOC, the leg of the callout is visible, if I insert the TOC again, the leg of the callout vanishes.
Comment 4 roumanet 2018-11-24 19:59:16 UTC
(In reply to Regina Henschel from comment #3)
> I can reproduce the problem with your document in Version: 6.3.0.0.alpha0+
> (x64)
> Build ID: 9e55c8c7ffc43004ca314edcd4712dcc29adf933
> CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
> Locale: de-DE (en_US); UI-Language: en-US
> Calc: threaded
> 
> I cannot produce the problem with a new document.
> 
> It seems to be somehow connected to the TOC. If I delete the TOC, the leg of
> the callout is visible, if I insert the TOC again, the leg of the callout
> vanishes.

What is the TOC ? could I delete it without datas lost ? thanks
Comment 5 Regina Henschel 2018-11-24 20:44:33 UTC
TOC = Table of Contents

Removing and newly inserting the table of content does not solve the problem for this document. I have tried that already. But because I could not reproduce the problem with a new document, it might help, if you make a new document and transfer the content from the old document into it. First load the styles from the old document, then copy and paste the content. If that does not solve the problem, try it without preserving the styles.
Comment 6 Xisco Faulí 2018-12-12 18:55:41 UTC
I can reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 3911bf8364dae4c855ad37237c114f9007f70657
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

I can't reproduce it on page 1, but I can on page 4
Comment 7 Xisco Faulí 2018-12-12 18:57:42 UTC
Not reproduced in

Version: 4.4.0.0.alpha2+
Build ID: b21df5a993a3815cf736fe3d2eab73eee646b38e