Bug 121829 - Linked section to protected (password or gpg encrypted) document does not work
Summary: Linked section to protected (password or gpg encrypted) document does not work
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section Password-Protected
  Show dependency treegraph
 
Reported: 2018-11-30 18:42 UTC by bugzilla
Modified: 2019-09-18 06:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case of password protected file not opening on section. (25.45 KB, application/zip)
2019-09-16 16:44 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2018-11-30 18:42:28 UTC
Description:
Creating a linked section to a document works when the document is not protected with password nor GPG encryption. 

It will not work if the linked document is either password protected or encrypted with GPG. It doesn't show the contents

Steps to Reproduce:
1. Create an ODT file with the contents and save it with a password or GPG encryption.
2. Create a new ODT file and insert a section linked to the first protected file.

Actual Results:
The contents of linked file does not show within the section.

Expected Results:
It should ask for a password or encryption key and then load the protected contents.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 bugzilla 2018-11-30 18:56:45 UTC
Additional Info:
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 6.1; UI render: default;
Calc: CL
Comment 2 Xisco Faulí 2019-01-14 17:04:09 UTC
> 
> Actual Results:
> The contents of linked file does not show within the section.

What happens if you double click on that section ? does it ask for the password then ?
Comment 3 bugzilla 2019-01-14 17:37:49 UTC
It only asks for password after selecting the protected file in Insert Section window, after that a box with a grey border is showed representing the section but with no content inside. Nothing happens when I double click it.

After saving the document with inserted section and opening it again, it asks:

"This document contains one or more links to external data.

Would you like to change the document, and update all links
to get the most recent data?"

It goes to the document with empty section and It does not ask for password after clicking 'Yes'. Nothing happens when I double click into the empty section.
Comment 4 Dieter 2019-08-19 05:47:15 UTC
It seems, that nobdy could reproduce this bug so far. So perhaps you can add two Please two sample documents, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 5 bugzilla 2019-09-16 16:44:51 UTC
Created attachment 154201 [details]
Test case of password protected file not opening on section.

View.odf has two sections. First is linked to password protected file and the second to another file not protected.
Comment 6 Dieter 2019-09-16 19:52:00 UTC Comment hidden (obsolete)
Comment 7 bugzilla 2019-09-17 20:57:52 UTC
I'm sorry. The password is 123
Comment 8 Dieter 2019-09-18 06:17:23 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Easier steps to reproduce
1. Insert section in a document
2. Context menu => Edit section
3. Add link to a password protected file => O.K.

Result: Content doesn't appear in section