Bug 121859 - Wrong convertion to .csv
Summary: Wrong convertion to .csv
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Export
  Show dependency treegraph
 
Reported: 2018-12-02 11:31 UTC by KES
Modified: 2019-05-07 09:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KES 2018-12-02 11:31:16 UTC
Description:
Hi.

I have field with value 1140. It has display format and displayed as 1,140.00

While converting to .csv the value should be converted as 1140, but it is converted to '1,140'

but this cause extra CSV field because ',' is separation

Steps to Reproduce:
1. create xls file with 1140 value which have display format 1,140.00
2. save file as .csv


Actual Results:
it results into two fields with values 1 and 140

Expected Results:
only one field should be: 1140


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2018-12-02 14:09:06 UTC
Thank you for reporting the bug. 
Please attach a sample document, as this makes it easier for us to verify the bug.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Julien Nabet 2018-12-03 08:10:52 UTC
Also, could you give a try to a recent LO version?
Last stable one is 6.1.3
Comment 3 Timur 2019-05-06 16:31:59 UTC
No response so I'll close. 
Feel free to set Unconfirmed if you attach sample document.
Comment 4 KES 2019-05-07 09:36:52 UTC
There was tick "save data as shown"
Without it data saved as expected.