Bug 121933 - Incorrect font shown in sidebar for presentation
Summary: Incorrect font shown in sidebar for presentation
Status: RESOLVED DUPLICATE of bug 100686
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Fonts Sidebar-Properties
  Show dependency treegraph
 
Reported: 2018-12-06 03:04 UTC by Aron Budea
Modified: 2020-12-26 02:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample PPTX (31.53 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-12-06 03:04 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-12-06 03:04:15 UTC
Created attachment 147309 [details]
Sample PPTX

The attached PPTX was created in PowerPoint, and has just some text in Comic Sans MS font (make sure to have it installed when checking in Linux).

In Impress, switch between the text boxes on a slide a few times.

=> The font shown in the sidebar is Calibri and Calibri Light.

Observed using LO 6.2 beta1 & 5.1.0.3 / Ubuntu 18.04.
No issue with LO 5.0.0.5.
=> regression

Bibisected to the following commit using repo bibisect-win32-5.1. Adding Cc: to Laurent Godard.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=187445b2d2885ced92be37ffb11cd2a9bb11f8d6
author		Laurent Godard <lgodard.libre@laposte.net>	2015-06-08 10:24:42 +0200
committer	Tomaž Vajngerl <quikee@gmail.com>	2015-06-23 06:38:56 +0000

Uno api sidebar unit test tdf#91806
Comment 1 Durgapriyanka 2018-12-12 18:11:58 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 2 QA Administrators 2020-12-12 03:48:18 UTC Comment hidden (obsolete)
Comment 3 Aron Budea 2020-12-12 10:18:01 UTC
This is good in a recent master build, closing as WFM. LO 7.2.0.0.alpha0+ (561e5559bb68242c7f785f0ca3bee3eb12b58963) / Windows.

I noticed the underlying issue, the particular sidebar font was there because if you select the text box itself (opposed to clicking into the text box as in the original description), the font in the picker is shown as Calibri, while it's Comic Sans MS in PowerPoint.
Comment 4 Aron Budea 2020-12-26 02:30:51 UTC
This is actually the duplicate of bug 100686.

*** This bug has been marked as a duplicate of bug 100686 ***