Bug 122132 - Frequent crashes on Mac OS Mojave
Summary: Frequent crashes on Mac OS Mojave
Status: RESOLVED DUPLICATE of bug 121778
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-16 00:34 UTC by Paul G
Modified: 2018-12-17 10:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul G 2018-12-16 00:34:43 UTC
Description:
Since upgrading my OS to Mojave 10.14.2, I experience frequent crashes of the OS, followed by extreme difficulty re-opening LibreOffice files.  Even when I close LibreOffice files, when attempting to reopen a file, I get the attempted recovery box.  The attempted recovery dialogue often leads to the dreaded Mac "wheel of fortune" and a frequent need to force quit the application and try again.  Can usually get recovery within 3-4 attempts, but sometimes takes many more tries.  Is there a compatibility problem between Libreoffice and Mojave??

Actual Results:
When either LibreOffice actually crashes, or the Mojave OS crashes, I have to go through the attempted recovery dialogue several times before being able to recover.  Have always been able to eventually recovery (at the last saved version), but it takes repeated attempts (application stops responding and I have to force quit and try again).

Expected Results:
Should be able to open a file I've saved and closed without have to go through "attempted recovery."


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-12-17 10:38:33 UTC
Could you please update LibreOffice to the 6.1.3(4) and retest ?
Meanwhile, I'm closing this issue as a duplicate of bug 121778

*** This bug has been marked as a duplicate of bug 121778 ***