Bug Hunting Session
Bug 122176 - UI: When using Presenter Console, after presentation some widgets get wrong background color.
Summary: UI: When using Presenter Console, after presentation some widgets get wrong b...
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: topicUI
Depends on:
Blocks: Presenter-Console
  Show dependency treegraph
 
Reported: 2018-12-18 14:21 UTC by gtxe
Modified: 2019-08-18 13:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Impress after presentation (114.93 KB, image/png)
2018-12-18 14:21 UTC, gtxe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gtxe 2018-12-18 14:21:33 UTC
Created attachment 147650 [details]
Screenshot of Impress after presentation

Because of this Bug: https://bugs.documentfoundation.org/show_bug.cgi?id=122161
I use the workaround described there. It overwrites the background color of fullscreen GTK window.

If the presenter console is enabled (default), dual screen setting, after ending/aborting the presentation, some UI elements switch to this color defined in the gtk.css.

Does not happen, if presenter console is disabled (still dual screen).
Comment 1 Xisco Faulí 2019-05-06 17:03:56 UTC
Hello gtxe,
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 gtxe 2019-05-07 19:30:15 UTC
Bug is still there.


Version: 6.2.3.2
Build-ID: 6.2.3-2
CPU-Threads: 4; BS: Linux 4.19; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.utf8); UI-Sprache: de-DE
Calc: threaded
Comment 3 gtxe 2019-05-08 15:34:03 UTC
The above test was with Manjaro (their own repository).

---

I did a new test with Kubuntu 18.04:

Bug is NOT solved here:
LibreOffice from PPA
https://launchpad.net/~libreoffice/+archive/ubuntu/ppa

SAL_USE_VCLPLUGIN=gtk3 libreoffice --impress

Version: 6.2.3.2
Build-ID: 1:6.2.3-0ubuntu0.18.04.1~lo1
CPU-Threads: 8; BS: Linux 4.18; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Some slide-effect not working (fading)

---

Bug is SOLVED here:
LibreOffice from Link (64bit deb)
https://www.libreoffice.org/download/libreoffice-fresh/

SAL_USE_VCLPLUGIN=gtk3 libreoffice6.2 --impress

Version: 6.2.3.2
Build-ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU-Threads: 8; BS: Linux 4.18; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

And, slide-effects are working right!
Comment 4 Buovjaga 2019-08-14 17:32:00 UTC
So you are saying Ubuntu's/Manjaro's packaged version is bad, while TDF packaged is good... I am tempted to say it is not our bug, then.

But please experiment with the latest versions, even 6.3.0

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 5 gtxe 2019-08-18 13:55:04 UTC
generaly yes, the TDF builds are working much better (very big difference) then Ubunut/Manjaro/Debian/Suse.
I did lots of testing. Specialy when PowerPoint files must be presented, with lot's of effects.
But it's not the topic here.

Problem still persists in all versions.
But it appears again in 6.2.3.2 (wich was working before).
I have no idea why, kernel-Update?!


Manjaro:
Version: 6.3.0.4
Build-ID: 6.3.0-0

Kubuntu 18.04 (PPA):
Version: 6.3.0.4
Build-ID: 1:6.3.0-0ubuntu0.18.04.1~lo2

Kubuntu 18.04 (fresh)
Version: 6.3.0.4
Build-ID: 057fc023c990d676a43019934386b85b21a9ee99


Kubuntu 18.04 (installed from archive)
Version: 6.2.3.2
Build-ID: aecc05fe267cc68dde00352a451aa867b3b546ac


btw. LibreOffice from 6.3 has sadly no KDE4 VCL anymore.