Download it now!
Bug 122205 - New installation: User-defined templates of previous version are not preserved
Summary: New installation: User-defined templates of previous version are not preserved
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-19 20:44 UTC by Christian Lehmann
Modified: 2018-12-22 07:27 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lehmann 2018-12-19 20:44:26 UTC
Description:
I had LO 6.1.3.2 and just installed 6.1.4.2. Some compnents of the previous installation, including user-defined dictionary and macros, gracefully reappear in the new installation, since they had been stored in my home folder (../.config/libreoffice/4/user/...). Other components, in particular the templates that I had defined, are not preserved, since they are in usr/lib/libreoffice/share/template/common, while the new installation is in /opt/libreoffice6.1. This is both inconsistent programming and a nuisance to the user.

Steps to Reproduce:
1. Leave your old LO version untouched.
2. Install the current version.
3. Start LO Writer.
4. Open the templates folder.

Actual Results:
It only contains those templates shipped with LO.

Expected Results:
It should contain the templates defined by the user in his previous version.


Reproducible: Always


User Profile Reset: No



Additional Info:
Suggestion: Either store all user-defined components in his home directory so they survive program updates; or else, when installing a new version, see to it that user-defined components are copied to their directories.
Comment 1 Christian Lehmann 2018-12-21 09:35:21 UTC
Update on the report:
I have just installed the Windows version of LO 6.1.4.2. Here the installer gets it right, since all the user settings are stored in subfolders of a folder 'user' at some point down the ramified structure headed by the folder 'Users'.
Comment 2 Christian Lehmann 2018-12-22 07:27:58 UTC
@Dieter:
I am not sure what you mean by 'Resolved'. Unless I am mistaken, you have a Windows system. The bug is on Linux.