Bug 122206 - FILEOPEN: Opening XML file with XSLT filter opens with plain text import dialogue
Summary: FILEOPEN: Opening XML file with XSLT filter opens with plain text import dial...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2018-12-19 21:44 UTC by Steve Edmonds
Modified: 2020-02-22 08:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test data XML file for import (4.77 KB, application/xml)
2018-12-19 21:47 UTC, Steve Edmonds
Details
XSLT filter for import of XML test file. (9.39 KB, text/plain)
2018-12-19 21:49 UTC, Steve Edmonds
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Edmonds 2018-12-19 21:44:28 UTC
Description:
Opening a XML file with File>Open and select my filter and then the XML file I get the text import dialogue and not a correct import.
A XML file will open correctly with Tools>XML Filter Settings, select filter and click "Test XSLTs..." 
Problem occurs on Calc 6.1.3.2 and not on Calc 6.0.5.2.

Steps to Reproduce:
1. Install XSLT XML filter
2. Go File>Open
3. Select XML filter above
4. Select XML file

Actual Results:
File opens in Calc

Expected Results:
Text import dialogue opens


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.3.2
Build ID: 10(Build:2)
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: gtk3_kde5; 
Locale: en-NZ (en_GB.UTF-8); Calc: group threaded
Comment 1 Steve Edmonds 2018-12-19 21:47:03 UTC
Created attachment 147682 [details]
Test data XML file for import

File to import
Comment 2 Steve Edmonds 2018-12-19 21:49:45 UTC
Created attachment 147683 [details]
XSLT filter for import of XML test file.

Import filter to install for importing test XML file
Comment 3 Oliver Brinzing 2018-12-21 14:51:43 UTC
i can not confirm with

Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

spreadsheet with caption and 3 data opens fine

Linux only?
Comment 4 Steve Edmonds 2018-12-22 01:37:40 UTC
Just noticed I have Actual and expected results back to front.
Should be;
Actual Results:
Text import dialogue opens

Expected Results:
File opens in Calc
Comment 5 raal 2018-12-26 07:55:05 UTC
I can not confirm with Version: 6.3.0.0.alpha0+
Build ID: 1b7bcaa714f0af45c6a9660d1f0940cb7931ba0f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
File opens without any dialog.
Comment 6 Xisco Faulí 2019-02-07 20:38:04 UTC
Hi Steve,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 Steve Edmonds 2019-02-12 08:01:23 UTC
Tested with 6.1.5.2 from https://www.libreoffice.org/download/libreoffice-fresh/
US language pack.

Bug not evident.
Comment 8 Xisco Faulí 2019-02-12 09:59:09 UTC
(In reply to Steve Edmonds from comment #7)
> Tested with 6.1.5.2 from
> https://www.libreoffice.org/download/libreoffice-fresh/
> US language pack.
> 
> Bug not evident.

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 9 Steve Edmonds 2019-02-12 18:47:39 UTC
Just tested with
Version: 6.1.5.2
Build ID: 10(Build:2) from  
https://download.opensuse.org/repositories/LibreOffice:/6.1/openSUSE_Leap_15.0/

and the problem persists so I am assuming this to be an OpenSUSE build issue.
Comment 10 jean.christophe.helary 2020-02-21 04:44:12 UTC
I confirm this is reproduced on my macos 10.15.3 / LO 6.3.1.2.

The file opens in the foremost opened application: either Calc, as text, where it triggers the text format import dialog, or Writer, in which it just opens in plain text.

I had exactly the same issue on a different file set and when faced with this problem I asked the user list where Steve told me it looked like his bug.
Comment 11 Alex Thurgood 2020-02-21 08:25:32 UTC
I can confirm this with 

Version: 6.4.0.0.alpha0+
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: GL; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2019-09-11_05:45:47
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded


Testing the XSLT against the XML file succeeds and displays the data in a Calc sheet, correctly separated into columns with the corresponding column headers.

However, dragging and dropping the XML file onto a Calc sheet, or dragging and dropping the XML file onto the StartCenter window of a running LO instance, opens the XML file as text, either in Calc via the text import wizard, which shows all of the XML, or else in Writer displaying the XML as text.
Comment 12 Alex Thurgood 2020-02-21 08:26:57 UTC
Just a bit of wild guessing here, but could this by any chance have anything to do with the addition of the new XML import feature for Calc ? Might that code be overriding the call to the XSLT filter ?
Comment 13 Steve Edmonds 2020-02-22 08:12:47 UTC
The new XML Source import seems to be an experimental feature in LO 6.3. I have tried with it enabled and with it disabled and I can no longer reproduce the bug on

Version: 6.3.5.2
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: en-NZ (en_US.UTF-8); UI-Language: en-US
Calc: threaded