Bug 122341 - UI hangs after selecting a featured FF persona
Summary: UI hangs after selecting a featured FF persona
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Firefox-Themes
  Show dependency treegraph
 
Reported: 2018-12-27 08:01 UTC by Gabor Kelemen
Modified: 2019-05-23 19:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Selecting an automatically loaded persona (121.96 KB, image/png)
2018-12-27 08:01 UTC, Gabor Kelemen
Details
Empty menu after selecting persona (34.53 KB, image/png)
2018-12-27 08:06 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-12-27 08:01:56 UTC
Created attachment 147851 [details]
Selecting an automatically loaded persona

When selecting a preloaded FF persona, the UI hangs and menus appear empty.

Steps to reproduce:
1, Select Options - Personalization
2, Click the Load Firefox Theme button
3, In the Select Firefox theme window click on any of the automatically loaded themes. Here I chose "Space Case".
4, Close the window. 

Menus and windows after this open as a grey emptiness.
The theme is not applied until restarting LO.

Version: 6.3.0.0.alpha0+
Build ID: 993913469e74e9db9743004bbe36aa412411671c
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 Gabor Kelemen 2018-12-27 08:06:07 UTC
Created attachment 147852 [details]
Empty menu after selecting persona

The pink theme here is of the preinstalled ones, those work fine.

Also: tried resetting the profile, but this does not help either.
Comment 2 Xisco Faulí 2018-12-27 09:41:06 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 936f6a85649c0fd71eee484e7399d445f4040586
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2018-12-27 09:42:17 UTC
Nor in

Versión: 6.2.0.1
Id. de compilación: 0412ee99e862f384c1106d0841a950c4cfaa9df1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Gabor Kelemen 2018-12-27 10:27:14 UTC
I used the bibisect-win32-6.3 repo and at one point I issued rm -rf instdir/user/
Comment 5 Roman Kuznetsov 2018-12-27 14:20:37 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: 49fcd3bbb30f93763fc5cb80fa6ac5cec5d00834
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-25_00:15:08
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2019-02-07 20:36:09 UTC
Hi Gabor,
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 7 Muhammet Kara 2019-05-23 19:01:24 UTC
Firefox/Mozilla personas feature was removed as per ESC and Design Team decisions.

Related patch: https://gerrit.libreoffice.org/#/c/72811/

Related bug report: https://bugs.documentfoundation.org/show_bug.cgi?id=125217