Bug Hunting Session
Bug 122346 - Font features set in dialog are not applied nor font is changed
Summary: Font features set in dialog are not applied nor font is changed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-12-27 16:39 UTC by Stanislav Horacek
Modified: 2019-01-21 01:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2018-12-27 16:39:22 UTC
It seems that the new Font features dialog introduced in 6.2 is not working properly.

1. Open a new Writer document.
2. Type "Dummy text" there.
3. Select the text and choose Format - Character.
4. Select font family "Linux Libertine O".
5. Click the "Features..." button.
6. In Font Features dialog, check "Lowercase to Small Capitals". Preview changes to the text in small capitals.
7. Click OK. Preview on the "Font" tab is not in small capitals, selected font family disappeared.
8. Click OK. "Dummy text" in the document has not been changed.

Expected: The text should be in small capitals.
If font family is explicitly specified as "Linux Libertine O:smcp", everything works fine.

Tested in Ubuntu 18.10.
Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Timur 2018-12-27 17:44:19 UTC
Reproduced in Windows with LO 6.3+ for "Linux Libertine" (all steps) and "Linux Biolinum" (except preview is OK in 6.).
Comment 2 V Stuart Foote 2018-12-27 19:33:53 UTC
Interesting in that if you make the change in the Formatting toolbar's Font listbox--appending the :smcp to the Linux Libertine G font name--the Small caps are correctly applied to the selection.

So while the Character dialog's Font Features... panel does show affect is applied in its preview, it is not actually being applied as DF to the selection when the Font Features panel is OK'd to close.
Comment 3 V Stuart Foote 2018-12-27 19:47:12 UTC
@Tomaž, any thought on what might have slipped since work on bug 58941, seems like the font name in the Formatting listbox is not being updated from the Font Features dialog--doesn't that name update have to occur for the OpenFont/Graphite  feature to apply?
Comment 4 Tomaz Vajngerl 2019-01-02 07:16:46 UTC
I didn't touch that code in 6.2 so I need to look which change has broken that.

Yes, font name should change if you apply a font feature (at least currently this is still true).
Comment 5 Xisco Faulí 2019-01-16 22:32:25 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2018-09-10 17:19:19 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-09-14 11:43:51 +0100
commit	9237a905fa5f2b67db73c15847eff203a258c2b4 (patch)
tree	bf213e7f3fd7322ee032af9fa648d04c99faaba1
parent	34f6b7f4529cc5a3b0e286fbd7318c2b7bf9b132 (diff)
weld SvxCharNamePage

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara

Once Lowercase to Small Capitals is selected the family dropdownlist should change to Linux Libertine G:smcp, however it becomes blank in GTK/GEN and the :smcp is not passed in GTK3
Comment 6 Commit Notification 2019-01-17 10:59:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/09513e0d5bfa00145374d195d605c33a8bc7113b%5E%21

Resolves: tdf#122346 get font features to stick in entry properly

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2019-01-17 11:01:33 UTC
backports to 6.2 in gerrit, fixed in master
Comment 8 Xisco Faulí 2019-01-17 14:36:44 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: edf8e2b6630ca9cf7117d9c7a25ef9d7231c5a9b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 6.3.0.0.alpha0+
Build ID: edf8e2b6630ca9cf7117d9c7a25ef9d7231c5a9b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Commit Notification 2019-01-17 14:43:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6561f24bf55c617efc8ac3aca503dee572f388ab%5E%21

Resolves: tdf#122346 get font features to stick in entry properly

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-01-20 21:03:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/326309ff3622c8e6b952b3ac80117335c0497411%5E%21

Resolves: tdf#122346 get font features to stick in entry properly

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.