Download it now!
Bug 122381 - LibreOffice Writer Menu and Toolbar Freezes for 5-10 Seconds when help pack is installed
Summary: LibreOffice Writer Menu and Toolbar Freezes for 5-10 Seconds when help pack i...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 122363 124733 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-30 16:58 UTC by Doug Lacy
Modified: 2021-01-04 02:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doug Lacy 2018-12-30 16:58:19 UTC
This problem also affects Calc in 6.1.4. I have not tried any other components. This problem has occurred since the first released version of the 6.1 series. It is severe enough that 6.1 is essentially unusable, and as a result I have had to fall back to the 6.0.7 version (where the problem does not occur).
Comment 1 Doug Lacy 2018-12-30 17:16:56 UTC
To reproduce on my system:

1. In a Writer ODT document, select some text in preparation (for example) to changing the font settings or style.
2. Move the mouse to over the toolbar, in preparation to clicking on the style dropdown or the B (to make the text Bold).
3. There is a delay of 5-10 seconds between moving the mouse over the desired effect and being able to click on it. Tooltips should appear while hovering, but don't for 5-10 seconds. Similarly, all menu items are unresponsive during this delay time.

I am running Windows 10 Pro (Version 1803, with the 2018-12 Update) on a Dell Precision T7500 with dual Xeon processors.
Comment 2 Julien Nabet 2018-12-30 19:25:43 UTC
Could you give a try to https://wiki.documentfoundation.org/QA/FirstSteps ?
Comment 3 Doug Lacy 2018-12-30 20:28:40 UTC
1. My version of LibreOffice is 6.1.4 (i.e., the latest Fresh version).
2. I renamed directory C:\Users\<myname>\AppData\Roaming\LibreOffice to C:\Users\<myname>\AppData\Roaming\LibreOffice.old and then started Writer. A new "LibreOffice" directory was created. The problem was still occurring.
3. The text of Help->About has the following text ...
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 16; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded

See log: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3

I believe that this is all the "First steps to take ..." that are relevant. The only other step on this page is related to Calc (which is also affected, but this bug is for Writer).
Comment 4 Dieter 2018-12-31 12:53:41 UTC
Sounds similar to bug 122363.
Comment 5 Doug Lacy 2018-12-31 14:06:08 UTC
It does sound similar to bug 122363.

For me, all the 6.0 series have been OK. I had a problem with 6.1.2, which was the first one that I installed, and every version of 6.1 that I installed since.

It is severe enough that I will have to uninstall 6.1 and revert to 6.0.7 (which was OK).

Before I do, is there anything that I can take do help resolve the problem? I have Visual Studio Community Edition installed, if that will help with debugging.
Comment 6 Dieter 2019-01-01 13:37:28 UTC
(In reply to Doug Lacy from comment #5)
> It does sound similar to bug 122363.

So do you think we can merge the two bugs?
 

> Before I do, is there anything that I can take do help resolve the problem?


Would be interesting to know, if the problem also occurs with LO 6.2 RC1 (but this will replace your actually installed verion of LO) or with the master from LO 6.3 (parallel installation)

link to master: https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/
Comment 7 Doug Lacy 2019-01-01 14:34:22 UTC
The problem is fixed in libo-master64~2018-12-24_22.40.25_LibreOfficeDev_6.3.0.0.alpha0_Win_x64.msi.

Note that I updated bug 122363 with comments intended for this bug by accident.

Marking as resolved.
Comment 8 Doug Lacy 2019-02-20 01:44:20 UTC
I installed the Released version of LibreOffice 6.2 (LibreOffice_6.2.0_Win_x64.msi) and the help (LibreOffice_6.2.0_Win_x64_helppack_en-US.msi) and the problem recurred.

I decided to fall back to the 6.1.5 release (LibreOffice_6.1.5_Win_x64.msi) to see if the problem was occurring with it also. I first installed it, and planned to test it and (if there was no problem) to install the help pack (LibreOffice_6.1.5_Win_x64_helppack_en-US.msi).

Version 6.1.5 was OK by itself, but the problem occurred when I installed the help pack. It was OK after I uninstalled the help pack. In other words, it's installing the help pack that caused the problem, at least with the 6.1.5 release.

I will try the 6.2.0 release by itself (i.e., no help pack) and see if the problem occurs with it alone. I will update this ticket after testing that.
Comment 9 Doug Lacy 2019-02-20 02:07:14 UTC
Installing 6.2.0.3 (LibreOffice_6.2.0_Win_x64.msi) by itself is OK. The problem occurs once the 6.2.0 help pack is also installed, and goes away when it's uninstalled.

I will leave version 6.2.0 installed (but without the help pack).
Comment 10 Dieter 2019-02-20 08:29:25 UTC
Olivier, you might be interested in this bug (see comment 8)

cc: Olivier Hallot
Comment 11 Dieter 2019-02-20 11:44:17 UTC
*** Bug 122363 has been marked as a duplicate of this bug. ***
Comment 12 Doug Lacy 2019-03-09 01:50:02 UTC
I just upgraded to LibreOffice 6.2.1, and the problem is still there. LO is unusable (slow) with the Help Pack installed, but very responsive if it isn't.
Comment 13 V Stuart Foote 2019-04-14 12:33:21 UTC
*** Bug 124733 has been marked as a duplicate of this bug. ***
Comment 14 Martin Srdoš 2020-12-29 06:42:27 UTC
Hello Doug,

I can't reproduce this bug on current release of LO.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
Comment 15 Dieter 2020-12-29 09:59:38 UTC
(In reply to Martin Srdoš from comment #14)
> I can't reproduce this bug on current release of LO.
> Could you please try to reproduce it with the latest version of LibreOffice
> from https://www.libreoffice.org/download/libreoffice-fresh/ ?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 16 Doug Lacy 2021-01-04 02:30:16 UTC
I am running LibreOffice 7.0.4 (which is the version that https://www.libreoffice.org/download/libreoffice-fresh/ brings me to), and do not have the problem.