Bug Hunting Session
Bug 122383 - Crash in: SvxConfigPage::InsertEntry(SvxConfigEntry *,SvTreeListEntry *,bool)
Summary: Crash in: SvxConfigPage::InsertEntry(SvxConfigEntry *,SvTreeListEntry *,bool)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: highest critical
Assignee: Muhammet Kara
URL:
Whiteboard: target:6.3.0 target:6.2.0.2 target:6.1.5
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2018-12-30 20:44 UTC by Thom
Modified: 2019-01-02 14:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SvxConfigPage::InsertEntry(SvxConfigEntry *,SvTreeListEntry *,bool)", "SvTreeListEntry::GetUserData()"]


Attachments
gdb backtrace (39.84 KB, text/plain)
2019-01-01 18:48 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thom 2018-12-30 20:44:01 UTC
This bug was filed from the crash reporting server and is br-ca32b19f-9d7e-4c67-a4b5-122da4b7d983.
=========================================
Fresh install of LibreOffice on Windows 10 OS.
Sequence leading to crash (this is repeatable & happens every time):
1. Start LibreOffice
2. Click Tools/Customize
3. Click Toolbars tab
4. Highlight any item in the LH "Function" window
5. Click the Right-arrow between the 2 windows.
6. Crash.
Comment 1 Thom 2018-12-30 21:04:35 UTC
Rebooted PC to see if that had any effect on the bug: No change, still there.
Comment 2 m.a.riosv 2018-12-30 21:36:07 UTC
Repro
crashreport.libreoffice.org/stats/crash_details/7975ad06-dd91-4be6-9682-e8d46464a3b1
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: es-ES (es_ES); Calc: CL

Versión: 6.0.7.1 (x64)
Id. de compilación: 5d2cb2a5dd04fe174b336488731eb50bbb5faed3
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: GL; 
Configuración regional: es-ES (es_ES); Calc: CL

On ver 5 IU was different
Comment 3 Oliver Brinzing 2018-12-31 09:12:31 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/c525dc764114f45ec9ff33837e8ae7cb74ce72b1

commit	c525dc764114f45ec9ff33837e8ae7cb74ce72b1	[log]
author	Muhammet Kara <muhammet.kara@pardus.org.tr>	
Thu Aug 17 06:48:08 2017 +0300
committer Katarina Behrens <Katarina.Behrens@cib.de>
Mon Sep 04 22:39:46 2017 +0200
tree	7b029314471346b747e5da16b363a5415f445173
parent	3e4de4d63c897fdaa885909f7abb1b3f111458d2 [diff]

Implement "Add" button in the Customize dialog
Now new commands can be added to Toolbars, Menus, and Context Menus
by using the Add (right arrow) button which is between the commands list
and the menu/toolbar entries list.

Change-Id: I9c094a5142f82922c5e5bc3075a35442875a5fec
Reviewed-on: https://gerrit.libreoffice.org/41240
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Katarina Behrens <Katarina.Behrens@cib.de>

92e96ac8d50f13cff157f4990323f5a842b8ffcd is the first bad commit
commit 92e96ac8d50f13cff157f4990323f5a842b8ffcd
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Sep 28 11:24:40 2017 -0700
    source sha:c525dc764114f45ec9ff33837e8ae7cb74ce72b1
    source sha:c525dc764114f45ec9ff33837e8ae7cb74ce72b1
:040000 040000 02c0fcef92df4771a17d2d806546f9792c81306e 0af2afed6679f8b4ad061e232b1f0971bf3dfa0e M      instdir

admin@latitude5530 /cygdrive/d/sources/bibisect/bibisect-win32-6.0
$ git bisect log
# bad: [bc1845d882e52469a4583747881a465749177829] source sha:c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
# good: [cc5c4c7ed1d8d01b0063bcaaeb5f6d59282c8029] source sha:9feb7f7039a3b59974cbf266922177e961a52dd1
git bisect start 'master' 'oldest'
# bad: [611b687719dc875499fd14d50e699b7ce871b941] source sha:2cd664b3d618e6085be8b44ee86eada6cd5f8789
git bisect bad 611b687719dc875499fd14d50e699b7ce871b941
# good: [1ab9d28e263358b2f569adb76bcc856198d0f435] source sha:ccb6513baf6eae9af40eecd05a2991bdd3ce3bbf
git bisect good 1ab9d28e263358b2f569adb76bcc856198d0f435
# good: [8c62e5fd421ccd2e5c767f4067798f7253965b76] source sha:19805f85b35672e6d0ee16f8fb4b79a3e94fc05d
git bisect good 8c62e5fd421ccd2e5c767f4067798f7253965b76
# good: [170117b65d6ac2520682aed591c5429310385e4d] source sha:6d8598acb23bbecb55ac235c15b9e01885588ad7
git bisect good 170117b65d6ac2520682aed591c5429310385e4d
# good: [58eed3875a0e92ceaf85c728d6bd1d4e084ac27c] source sha:9d4fc496d498f2f5c7fedba94f656ef3189b85dd
git bisect good 58eed3875a0e92ceaf85c728d6bd1d4e084ac27c
# bad: [23154bc8740720a2b133f8e4d8bdfefa303b72f0] source sha:4829d41c89acbf29db6414d026275829cf69bdc1
git bisect bad 23154bc8740720a2b133f8e4d8bdfefa303b72f0
# bad: [ce9734666dec232c705b62f1adc157eab5867c88] source sha:862b968d1c015bca2226f18c767d350da63517c8
git bisect bad ce9734666dec232c705b62f1adc157eab5867c88
# good: [f5554e51cc8bce829009f82f34ae29a0a01fe1a9] source sha:04749a1115a44ce7a2d05c1ea6c23613feded5f9
git bisect good f5554e51cc8bce829009f82f34ae29a0a01fe1a9
# good: [55a9340049231088d7a1dc83d43bbd785fd4bd66] source sha:72b19aa29f9adcab6dd20d1517208f3b999d055e
git bisect good 55a9340049231088d7a1dc83d43bbd785fd4bd66
# good: [cc7d4171d9a9b1df2da7df4bd964c3453698f561] source sha:283280ec542883d65cc97d4228434003a01be3e9
git bisect good cc7d4171d9a9b1df2da7df4bd964c3453698f561
# bad: [a26df2887ffffc7d2c1c6e40f7a6ddc7abf1ea5c] source sha:60d622d807f4f3bcc8a699458adf5d6690f9dc4b
git bisect bad a26df2887ffffc7d2c1c6e40f7a6ddc7abf1ea5c
# good: [4d569c7169a9fee657dd141e8263d1bda731ee0c] source sha:3e4de4d63c897fdaa885909f7abb1b3f111458d2
git bisect good 4d569c7169a9fee657dd141e8263d1bda731ee0c
# bad: [92e96ac8d50f13cff157f4990323f5a842b8ffcd] source sha:c525dc764114f45ec9ff33837e8ae7cb74ce72b1
git bisect bad 92e96ac8d50f13cff157f4990323f5a842b8ffcd
# first bad commit: [92e96ac8d50f13cff157f4990323f5a842b8ffcd] source sha:c525dc764114f45ec9ff33837e8ae7cb74ce72b1
Comment 4 Xisco Faulí 2019-01-01 18:21:07 UTC
Also reproduced in

Version: 6.1.4.2
Build ID: 1:6.1.4-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2019-01-01 18:23:21 UTC
Adding Cc: to Muhammet Kara
Comment 6 Xisco Faulí 2019-01-01 18:29:01 UTC
So, the problem is only reproducible when calling the customize dialog from the start center. not happening if it's called from Writer/Calc/etc...
Comment 7 Xisco Faulí 2019-01-01 18:48:39 UTC
Created attachment 147925 [details]
gdb backtrace
Comment 8 Commit Notification 2019-01-02 00:08:44 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/be8897d9c63a77b223a9c0aed1d2eb689e0e0082%5E%21

Resolves tdf#122383 and tdf#122410

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-01-02 06:35:33 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/bd9f2037f379cc3cd887122ca34eedfe85e4e820%5E%21

Resolves tdf#122383 and tdf#122410

It will be available in 6.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-01-02 06:37:00 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/808cc4d5fd87e6e6719a4a16f815e5897608bd2d%5E%21

Resolves tdf#122383 and tdf#122410

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-01-02 14:17:45 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 49c61f660d05ab13140d4349a0b3f6efba742022
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Muhammet Kara, thanks for fixing this!!
Comment 12 Xisco Faulí 2019-01-02 14:22:28 UTC
This also fixes this crash -> http://crashreport.libreoffice.org/stats/crash_details/c37dbcf5-b0c2-44b1-aa6a-018832fd7042