Download it now!
Bug 122423 - DOCX Import Tab settings in bulleted lists with custom style and direct formatting look different when opened in Writer
Summary: DOCX Import Tab settings in bulleted lists with custom style and direct forma...
Status: RESOLVED DUPLICATE of bug 78352
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2019-01-02 15:07 UTC by NISZ LibreOffice Team
Modified: 2020-06-02 09:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot showcasing the issue. (269.61 KB, image/png)
2019-01-02 15:08 UTC, NISZ LibreOffice Team
Details
Example file from Word (18.69 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-02 15:08 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in Word and Writer (166.70 KB, image/png)
2020-05-28 10:34 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-02 15:07:54 UTC
Description:
Microsoft Word has a very... unique way to handle lists with tabs and custom styles, which is not interpreted well in LibreOffice Writer in some cases. The result of this is different text positioning (effective tab sizes) in bulleted lists.

Steps to Reproduce:
    1. Create a simple document with a bulleted list in Microsoft Word and select it.
    2. Adjust List Indents (Right click on the list > Adjust List Indents) as follows: Bullet position 5 cm ; Text indent: 5,5 cm ; [X] Add tab stop at: 5,5 cm
    3. Create a New Style;
    4. Change the left indent from 5 cm to 0,5 cm in the paragraph settings of the newly created style with the following setting.
    5. Save the file as DOCX, open it in LibreOffice Writer and compare the two.

Actual Results:
Both Microsoft Word and LibreOffice Writer keep the original tab settings in the Adjust Line Indents (MSO) / Bullets and Numbering (LO) windows, but only LibreOffice Writer actually applies the setting (5,5 cm) resulting a different text position after the bullet.


Expected Results:
LibreOffice Writer should position the text after the bullet just like Microsoft Word does when importing the DOCX file.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-02 15:08:30 UTC
Created attachment 147938 [details]
A screenshot showcasing the issue.
Comment 2 NISZ LibreOffice Team 2019-01-02 15:08:48 UTC
Created attachment 147939 [details]
Example file from Word
Comment 3 Durgapriyanka 2019-01-02 21:40:21 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-01-16 18:26:06 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8fd13c356d78fb72ba5dd288a495551f23e15363

author	Justin Luth <justin_luth@sil.org>	2018-01-23 14:41:48 +0300
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-01-25 13:39:17 +0100
commit	8fd13c356d78fb72ba5dd288a495551f23e15363 (patch)
tree	dfd8ec1bc91edeccb24c0e251eabf47e382aca71
parent	f82434b54517cad96416df93e9b5d70c9b0ada45 (diff)
ooxmlimport: support inherited listid

Bisected with: bibisect-linux64-6.1 

Adding Cc: to Justin Luth
Comment 5 Justin L 2019-01-17 15:02:15 UTC
There are two visual things going on here.  The first one is the starting position, and the second is the distance between the bullet point and the text. Prior to the identified patch, the starting position was near the centre of the page (bad), with the text nearby (good).  After the patch, the starting point is approximately in the correct place (good), but the tabstop has kept the text roughly in the same spot in the centre of the page (nochange).
Comment 6 Justin L 2019-01-18 10:24:11 UTC
In the old version Word 2003, there is also a large gap - identical to LO6.1
Comment 7 Justin L 2019-01-19 17:26:46 UTC
There seems to be two problems. 1.) The style's hanging indent doesn't seem to be applied.  I could make an argument for
 -          if (nParaRightMargin != 0)
 +          if ( true )

Secondly, even when that is done, the layout doesn't change, even though the paragraph margins look correct.  If you change the left/first paragraph margins, and then change them back, then it IS laid out correctly (especially if you visit the tab page and notice that no tabs are set).
Comment 8 NISZ LibreOffice Team 2020-05-28 10:34:06 UTC
Created attachment 161362 [details]
Screenshot of the original document in Word and Writer

This one looks good now in:

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 41d8b41767032681a9897b7551f011d450e3725e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Likely because of bug #78352 was solved, but I have no fresh bibisect repo at hand.
Comment 9 NISZ LibreOffice Team 2020-06-02 09:09:09 UTC
Verified with bibisect-win64-6.5 that this started to look good since the fix to bug #78352

*** This bug has been marked as a duplicate of bug 78352 ***