Download it now!
Bug 122458 - Heading 1 style font (and others) fail to update when font family of parent Heading is changed
Summary: Heading 1 style font (and others) fail to update when font family of parent H...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.1.5 target:6.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Styles-Heading
  Show dependency treegraph
 
Reported: 2019-01-04 04:41 UTC by Luke Forbach
Modified: 2019-01-22 18:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Font Display Mismatch (328.04 KB, image/jpeg)
2019-01-08 20:47 UTC, Luke Forbach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Forbach 2019-01-04 04:41:08 UTC
Description:
Unaltered sublevel heading styles will change to the correct font, but adding a before text indent to the style causes it to not display the updated font. However, if the cursor is positioned in the text formatted by that style, though the font displayed has not updated, the font name text box displays the new font name. Any additional alteration to the specific sublevel formatting will cause the font to update.

Steps to Reproduce:
1. Type text formatted as any of the heading styles.
2. Modify that specific heading style to have a before text indent.
3. Modify top level heading style to new font.

Actual Results:
Text does not update to new font.
Font name text box does update to new font.
Additional modification to specific heading used causes displayed font to update.

Expected Results:
Text is displayed in same font as displayed in Font Name text box.


Reproducible: Always


User Profile Reset: No



Additional Info:
Occurs in 6.1.4.2 in both Windows and Linux
Comment 1 Dieter 2019-01-04 07:31:07 UTC
(In reply to Luke Forbach from comment #0)

> 3. Modify top level heading style to new font.

Just for clarification: "Top level heading style" is style "heading", right?
Comment 2 Luke Forbach 2019-01-04 17:11:29 UTC
(In reply to Dieter Praas from comment #1)
> (In reply to Luke Forbach from comment #0)
> 
> > 3. Modify top level heading style to new font.
> 
> Just for clarification: "Top level heading style" is style "heading", right?

That is correct.
Comment 3 Dieter 2019-01-07 20:34:26 UTC
I can't confirm this with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

Please check, if AutoUpdate is enabled in the Style Dialog of the different heading styles (Tab Organizer)
Comment 4 Luke Forbach 2019-01-08 20:47:34 UTC
Created attachment 148148 [details]
Screenshot of Font Display Mismatch

JPEG Screenshot of LibreOffice 6.1.4.2 on Windows 10 showing text displayed in Liberation Sans where Font Name text box shows Liberation Serif.
Comment 5 Luke Forbach 2019-01-08 20:54:37 UTC
(In reply to Dieter Praas from comment #3)
> I can't confirm this with
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
> CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
> Locale: en-US (de_DE); UI-Language: en-US
> Calc: threaded
> 
> Please check, if AutoUpdate is enabled in the Style Dialog of the different
> heading styles (Tab Organizer)

AutoUpdate was not enabled in my initial tests, enabling makes no difference.
Comment 6 Luke Forbach 2019-01-08 21:01:35 UTC
Additional Note: Issue does not persist upon closing and reopening document.
Comment 7 Buovjaga 2019-01-15 17:19:41 UTC
Repro and bibisected with win32-6.1 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/903e664735b6bb0d58a16e08db8dfcb3fe52ed94%5E!/ which is a backport of https://gerrit.libreoffice.org/plugins/gitiles/core/+/8b0dae14a5af0ad2892bac0e606467af6148c8d1%5E!/

weld SvxStdParagraphTabPage

Adding Cc: to Caolán McNamara
Comment 8 Commit Notification 2019-01-16 12:52:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/276b46ee53b82f409a451ae8324c1a12e2abb38e%5E%21

Resolves: tdf#122458 not enough values saved

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2019-01-16 13:00:15 UTC
fixed in master, backports in gerrit
Comment 10 Buovjaga 2019-01-16 15:21:06 UTC
Nice, it works now!

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 276b46ee53b82f409a451ae8324c1a12e2abb38e
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 16 January 2019
Comment 11 Commit Notification 2019-01-16 19:07:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/850d31f97e1f47b646a9e296183b142dbfe0ba9b%5E%21

Resolves: tdf#122458 not enough values saved

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Cor Nouws 2019-01-18 17:33:00 UTC
*** Bug 122743 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2019-01-21 16:52:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/ef18fde840c1738a3e113b4a0f740eaf997e59b6%5E%21

Resolves: tdf#122458 not enough values saved

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-01-22 17:11:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/636898660b09382054855c5eaca3c79eb3bbeee3%5E%21

Resolves: tdf#122458 not enough values saved

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.