Bug Hunting Session
Bug 122550 - Crash in: ScPoolHelper::GetFormTable
Summary: Crash in: ScPoolHelper::GetFormTable
Status: RESOLVED DUPLICATE of bug 121949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-07 20:37 UTC by mikael79+LOfficebugzilla
Modified: 2019-01-07 23:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["ScPoolHelper::GetFormTable"]


Attachments
test document which illustrates crash (17.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-07 23:21 UTC, mikael79+LOfficebugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikael79+LOfficebugzilla 2019-01-07 20:37:48 UTC
This bug was filed from the crash reporting server and is br-c5232528-b6db-4267-a503-bd74a1779c1d.
=========================================

Crash when selecting cells in the cell block (array?) generated by the multivariate regression tool.

Does not happen every time I click in one of those cells, but it has happened about a dozen times so far today. 
It seems to be that selecting several cells at once (i.e. if I want to delete the result to recalculate with different inputs) is more likely to trigger the crash than selecting a single cell.
Comment 1 Xisco Faulí 2019-01-07 22:28:19 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Xisco Faulí 2019-01-07 22:29:23 UTC
Seems like a dupe of bug 121949

*** This bug has been marked as a duplicate of bug 121949 ***
Comment 3 mikael79+LOfficebugzilla 2019-01-07 23:21:16 UTC
Created attachment 148121 [details]
test document which illustrates crash

Seemingly surefire of recreating the crash: Select cell H1. Click and drag to select a larger set of cells, downwards and to the right.