Bug Hunting Session
Bug 122635 - Assert when pressing animation icon on the sidebar
Summary: Assert when pressing animation icon on the sidebar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar Assert
  Show dependency treegraph
 
Reported: 2019-01-10 14:21 UTC by Mark Hung
Modified: 2019-01-20 16:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2019-01-10 14:21:38 UTC
Description:
Crash when pressing animation icon on the sidebar

Steps to Reproduce:
1. Delete the profile. (Does not happen if you switch icons to other than colibre first. )
2. Lunch Impress.
3. Press animation icon on the sidebar.

Actual Results:

Program crashes.
From my console:
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:61: Failed to load scaled image from extensions/res/buttonminus.png at 1
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:83: Failed to load stock icon extensions/res/buttonminus.png
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:61: Failed to load scaled image from extensions/res/buttonminus.png at 1
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:83: Failed to load stock icon extensions/res/buttonminus.png
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:61: Failed to load scaled image from extensions/res/buttonminus.png at 1
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:83: Failed to load stock icon extensions/res/buttonminus.png
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:61: Failed to load scaled image from extensions/res/buttonminus.png at 1
warn:vcl:13828:13220:vcl/source/image/ImplImage.cxx:83: Failed to load stock icon extensions/res/buttonminus.png
Assertion failed: xImpBmp && "Forbidden Access to empty bitmap!", file E:/lode/dev/core/vcl/source/gdi/bmpacc.cxx, line 39


Expected Results:
It should not crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-01-10 14:55:56 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: a5aeb6b52327565523be406e0082fe0122c48e03
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

with a clear profile
Comment 2 Xisco Faulí 2019-01-10 14:56:29 UTC
nor in

Version: 6.3.0.0.alpha0+
Build ID: b8f497a06d585dbae3adadb4d177fe84fdb1b5fa
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-01-11 15:09:35 UTC
@Mark Hung,
Do you use a debug build ?
Comment 4 Mark Hung 2019-01-12 05:57:23 UTC
@Xisco

Yes. It's a debug build.

版本:6.3.0.0.alpha0+ (x64)
組建 ID:24613d7abf820aff639a276a1819ada8d83e9063
CPU 執行緒:8; OS:Windows 10.0; UI 算繪:預設; VCL: win; 
語言地區:zh-TW (zh_TW); UI語言:zh-TW
Calc: threaded
Comment 5 Xisco Faulí 2019-01-12 16:22:39 UTC
Ok, let's change the wording then...
Comment 6 Julien Nabet 2019-01-19 15:41:03 UTC
On pc Debian x86-64 with master sources updated yesterday + enable-dbgtutil, I don't reproduce this with gtk3 or gen rendering.
Comment 7 Mark Hung 2019-01-19 18:11:10 UTC
Caolan told me he had fixed this issue. ( I forgot to record the commit id. )  I did a make clean and rebuilt, then the issue disappeared. Thanks for all your help.
Comment 8 Xisco Faulí 2019-01-20 16:24:08 UTC
(In reply to Mark Hung from comment #7)
> Caolan told me he had fixed this issue. ( I forgot to record the commit id.
> )  I did a make clean and rebuilt, then the issue disappeared. Thanks for
> all your help.

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.