Bug 122661 - FORMS: Borders of form-controls set to 'FLAT' style are so narrow and light as to be all but lost to view
Summary: FORMS: Borders of form-controls set to 'FLAT' style are so narrow and light a...
Status: RESOLVED DUPLICATE of bug 122358
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Database-Forms
  Show dependency treegraph
 
Reported: 2019-01-11 18:48 UTC by Robert Großkopf
Modified: 2019-07-29 18:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-01-11 18:48:56 UTC
Open any existing database.
Open any form.
Have a look a the borders of any form-control except table-control.
All borders aren't shown any more.

This bug happens
Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Doesn't appear with LO 6.1.4.2 on OpenSUSE 15 64bit rpm Linux.

Note: Also the whole menubar is disabled when opening the form. Something is running totally wrong here.
Comment 1 Drew Jensen 2019-01-11 19:55:49 UTC
Confirmed (some of this) with Ubuntu 18.04.1 and LO
Version: 6.2.0.2
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 


First - the borders; this is a problem only when the controls are set to style 'FLAT'. The borders are now very thin and a very light grey, on light backgrounds (such as white) they are easily missed. 

Second - The highlighting of selected control by changing the border color to blue is not happening at all. (I think that is worth a separate issue, but I'll hold off on entering to give people a chance to speak if they think this issue should cover both)

A good example database to see this is attached to https://bugs.documentfoundation.org/show_bug.cgi?id=122358

Steps to reproduce:

1 - download the attached zip file, extract the odb and open it
2 - open the single form in the file
3 - select any of the controls on the left side of the form

results: 
The controls look almost as if they have no border at all. (it appears that the controls in FLAT style use the same border settings that the lower and right borders use when the style is set to 3D.)

The control border of the selected control did not highlight by changing to blue.

expected:
The controls should have a visually stronger border on all sides when style is FLAT.
A control set to style FLAT should display a highlighted, in blue, border when receiving focus and revert to the default border when losing it.
Comment 2 Drew Jensen 2019-01-11 19:56:21 UTC
I did not find any issues with the toolbar in my testing.
Comment 3 Robert Großkopf 2019-01-12 07:14:00 UTC
(In reply to Drew Jensen from comment #2)
> I did not find any issues with the toolbar in my testing.

Have a look at this screenshot:
https://bugs.documentfoundation.org/attachment.cgi?id=148257
Comment 4 Alex Thurgood 2019-01-14 15:41:30 UTC
Not just Linux, I can reproduce this on macOS 10.14.2 with LO6202RC
Comment 5 Xisco Faulí 2019-01-14 19:15:06 UTC
Regression introduced by:

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-05 23:34:32 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-07 10:16:39 +0200
commit	32d49d077fff5c63ec731191bff4daed06744afa (patch)
tree	e1cdfbad4678b38ffc06b8465a4eeb139fda0b76
parent	66c3c53d1951bed03173415d9bce1d7c1e5ac960 (diff)
Cleanup SvpSalGraphics LineGeometry creation

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 6 Xisco Faulí 2019-07-29 18:27:30 UTC
This is a duplicate of bug 122358 and it has improved after https://cgit.freedesktop.org/libreoffice/core/commit/?id=e18dbb2b7f48a1380e9d1cb6443705d1ce2b2ad5

*** This bug has been marked as a duplicate of bug 122358 ***