Bug 122670 - command line option --ver
Summary: command line option --ver
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Commandline
  Show dependency treegraph
 
Reported: 2019-01-12 11:08 UTC by Luuk
Modified: 2019-01-15 18:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luuk 2019-01-12 11:08:41 UTC
Description:
D:\TEMP>tasklist  | findstr "soffice"

D:\TEMP>"C:\Program Files\LibreOffice\program\soffice.exe" --version

D:\TEMP>
LibreOffice 6.1.4.2 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3


D:\TEMP>"C:\Program Files\LibreOffice\program\quickstart.exe"

D:\TEMP>"C:\Program Files\LibreOffice\program\soffice.exe" --version

** A new window is openeed with the text:
LibreOffice 6.1.4.2 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3

Press Enter to continue...
** Any input in this windows is 'ignored' (there is no continuation!)

D:\TEMP>tasklist | findstr "soffice"
soffice.exe                   7676 Console                    2      5.384 K
soffice.bin                   9248 Console                    2     51.940 K

D:\TEMP>

** Closing the window with version nummber using the "X" (upper right corner) to close

D:\TEMP>"C:\Program Files\LibreOffice\program\soffice.exe" --version

D:\TEMP>

** No result is shown about version, also no popup!


Steps to Reproduce:
see description

Actual Results:
see description

Expected Results:
see description


Reproducible: Always


User Profile Reset: No



Additional Info:
possible relation to bug 117312 ??
Comment 1 Luuk 2019-01-12 11:20:10 UTC
After reboot, and reset of userprofile the problem is the same.

User Profile Reset: Yes
Comment 2 Oliver Brinzing 2019-01-13 09:18:06 UTC
reproducible - if quickstart is running "soffice.exe --version" opens a new window. after closing via "X", "soffice.exe --version" produces no output.
Comment 3 Mike Kaganski 2019-01-15 18:25:06 UTC
After https://git.libreoffice.org/core/+/c13529cd2e20a0aca6f1d4cd0c85a36ab2f54afb, this is already fixed (i.e., the output will not go to a separate window, although the previous behavior with separate window was also expected - what wasn't was the problems with continuation or no output after first closing).