Download it now!
Bug 122680 - Proposal: Enable sd Color toolbar by default in Draw
Summary: Proposal: Enable sd Color toolbar by default in Draw
Status: RESOLVED DUPLICATE of bug 120230
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Draw-UX
  Show dependency treegraph
 
Reported: 2019-01-12 19:29 UTC by Pedro
Modified: 2019-01-13 11:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Inkscape - notice color bar at the bottom (84.21 KB, image/png)
2019-01-12 19:29 UTC, Pedro
Details
Impress Color bar below Page pane on the right side (87.06 KB, image/png)
2019-01-12 19:32 UTC, Pedro
Details
Color bar shows colors stretched out into rectangles as opposed to Inkscape's (90.22 KB, image/png)
2019-01-12 19:33 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2019-01-12 19:29:33 UTC
Created attachment 148272 [details]
Inkscape - notice color bar at the bottom

Vector drawing applications like Inkscape usually present a colour bar visible by default.

Proposal:
1 - Since Draw is a vector drawing application so the Colour bar (accessible via View > Toolbars > Colour Bar) should be active by default in Draw whenever an user starts this module.

2 - Considering that the color bar in Draw shows the colors inside of extremely stretched rectangles instead of squares I propose that the colour bar is presented on the left below the Page pane.

Alternative:
3 - Fix the way that colors are presented when the Colour Bar is placed horizontally so that colors are visible inside squares similar to Inkscape instead of rectangles.
Comment 1 Pedro 2019-01-12 19:32:19 UTC
Created attachment 148273 [details]
Impress Color bar below Page pane on the right side

Proposal:
Color bar should be visible by default like this.
Comment 2 Pedro 2019-01-12 19:33:56 UTC
Created attachment 148274 [details]
Color bar shows colors stretched out into rectangles as opposed to Inkscape's

To place the Color bar horizontally, the colors should not occupy more than a square instead of those enormous rectangles.
Comment 3 Roman Kuznetsov 2019-01-12 19:50:51 UTC
Enh about Draw
Comment 4 V Stuart Foote 2019-01-13 02:04:50 UTC
A rework of the sd Color Bar is already being considered for bug 120230, adopting the color picker may or maynot be the end design.  Enabling the bar element by default but in a collapsed state might also appeal to folks.

Also keep in mind that the Color Bar responds to the width of the pane holding the drawing canvas, and can be dragged taller to display more color swatches--meaning the swatches are not fixed width just a fixed height currently. 

Also its current default view of three lines could be changed--new default, or customizable.

*** This bug has been marked as a duplicate of bug 120230 ***