Download it now!
Bug 122683 - Copy only visible cells
Summary: Copy only visible cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-13 05:01 UTC by Franklin Schiftan
Modified: 2019-01-13 14:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
copying table with autofilter (27.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-13 10:43 UTC, Franklin Schiftan
Details
Receiving table (14.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-13 10:44 UTC, Franklin Schiftan
Details
receiving_table_after_copy.ods (25.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-01-13 13:09 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Schiftan 2019-01-13 05:01:27 UTC
In earlier versions of LibO-Calc the hidden cells (e.g. via filter) were not copied, so that you could continue working with the visible cells. In version 6.1.4.2 the hidden cells are also copied. How can one copy only the visible cells in version 6.1.4.2?
Comment 1 Franklin Schiftan 2019-01-13 09:09:41 UTC
My question is not really answered in the original bug (36466), but in the meantime I found that it works again with the mentioned Extensison, in version 2.
Comment 2 Oliver Brinzing 2019-01-13 09:47:41 UTC
i cannot reproduce with:

Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

with applied autofilter:
- only visible rows are copied.

without autofilter and manually hidden rows:
- visible and hidden rows are copied

for me this works like expected.

Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 Franklin Schiftan 2019-01-13 10:34:18 UTC
It seems to be due to the receiving table what is important after copying. Once the content has been pasted into a table that *unfiltered* records and displays everything, the copy is also pasted unfiltered into the source table (on a second sheet). In the same worksheet, pasting works correctly the first time.
Comment 4 Franklin Schiftan 2019-01-13 10:43:47 UTC
Created attachment 148285 [details]
copying table with autofilter
Comment 5 Franklin Schiftan 2019-01-13 10:44:28 UTC
Created attachment 148286 [details]
Receiving table
Comment 6 Oliver Brinzing 2019-01-13 12:24:12 UTC
Could you please add a detailed description how the bug can be reproduced 
with attached documents?

I have set the bug's status to 'NEEDINFO'. 
Please change it back to 'UNCONFIRMED' once the requested info is provided.
Comment 7 Franklin Schiftan 2019-01-13 12:44:12 UTC
Download the two files. Open the file copying_table.ods, e.g. select all records with the autofilter where the field 'valid to' is empty. Then select the cells E176 to A1 and copy them with <strg><c>. Then open the file receiving_table.ods, and press with selected cell A1 <strg><v> to paste the copied cells. Then you will see ALL entries in column E, including the filtered records with a value in column 'valid to'.
Comment 8 Oliver Brinzing 2019-01-13 13:09:49 UTC
Created attachment 148288 [details]
receiving_table_after_copy.ods

- open "copying_table.ods"
- select "Empty" from column E
- select A1:E176
- copy
- open "receiving_table.ods"
- select A1
- paste
- result: A1:E99 is filled with copied data
  as shown in attached "receiving_table_after_copy.ods"
Comment 9 Franklin Schiftan 2019-01-13 14:08:30 UTC
Funny, now it's possible here too ... no idea why it did not work before and ALL records were displayed after inserting ... Strange, but thanks for trying it out!
Comment 10 Oliver Brinzing 2019-01-13 14:17:22 UTC
ok, closing/WORKSFORME