Download it now!
Bug 122712 - corrupted drawing on loading .svg file
Summary: corrupted drawing on loading .svg file
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2019-01-14 18:46 UTC by mcbob
Modified: 2019-12-19 09:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
small .svg file that is corrupted on loading (1.13 KB, image/svg+xml)
2019-01-14 18:50 UTC, mcbob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mcbob 2019-01-14 18:46:36 UTC
Description:
I created a simple drawing in piglet and exported a .svg file.  I am unable to select rectangles in 6.14 for editing.  If I first load the file into 5.2 and save it as .odg, then I can edit it in 6.1 and add the desired fill.  Loading the .svg into 6.1 and saving it as .odg does not fix the problem.  Seems like file corruption to me.

Steps to Reproduce:
1.Start DRAW
2.file->edit
3.choose test.svg
4. Try to select any of the rectangles

Actual Results:
The outline of the drawing is selected instead.

Expected Results:
One of the rectangles should be selected.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.1.4.2
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 4; OS: Linux 3.16; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group threaded
Comment 1 mcbob 2019-01-14 18:50:13 UTC
Created attachment 148312 [details]
small .svg file that is corrupted on loading
Comment 2 Roman Kuznetsov 2019-01-14 19:12:25 UTC
mcbob, you should right click on svg in Draw and select context menu item Convert to->Polygon, then you select shape, right click on it and select context menu item Ungroup.
And you get your rectangles as different shapes.

Armin, is it a bug or it's expected behavior when insert SVG file into Draw?
Comment 3 mcbob 2019-01-15 17:19:43 UTC
I just tried it on 6.0.7.3 (stable), and the file is loaded correctly
It fails in 6.1.4.2 as I originally reported.
I also tried 6.2.0.2, and the problem is still there

This is not a rendering problem.  I don't think  it has anything to do with the graphics stack.  This is file corruption on load.  It does not appear in the stable released versions.
Comment 4 mcbob 2019-01-15 17:24:50 UTC
Roman, I do not get that context menu.  On loading the file it seems that the .svg has been inserted into a blank file rather than opening the file for editing.  I cannot select or edit anything inside the .svg.  None of the stable versions have this problem as far as I know.
Comment 5 mcbob 2019-01-15 19:24:51 UTC
Roman, I tried again and found the menu item.  That does indeed fix the drawing.

Ungrouping was not required in any previous version that I have used.  It is
a change in behavior that will confuse others as well as me.

I leave it for you guys to decide whether this is a bug or a feature.

Thanks for the help.
Comment 6 Buovjaga 2019-07-13 15:44:18 UTC
Just to confirm, this change is due to https://gerrit.libreoffice.org/plugins/gitiles/core/+/3ca7be09834a26fbd1c371deabd7a58111092676%5E!/
Replace SVGFilter using SVGIO
Comment 7 Xisco Faulí 2019-12-19 09:31:35 UTC
Hello mcbob,
How to do it in LibreOffice 6.3, 6.4 or master
1. Open svg file with Draw
2. Right click - break

-> Now you can edit the different rectangles for edition.
Closing as RESOLVED NOTABUG