Bug 122719 - DOCX: wrong result of calculation in table with function SUM(LEFT)
Summary: DOCX: wrong result of calculation in table with function SUM(LEFT)
Status: RESOLVED DUPLICATE of bug 123355
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Tables DOCX-Fields Regressions-expression-is-faulty
  Show dependency treegraph
 
Reported: 2019-01-15 08:47 UTC by Roman Kuznetsov
Modified: 2020-09-16 07:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with table and function SUM(LEFT) (13.06 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-15 08:47 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-01-15 08:47:10 UTC
Description:
DOCX: wrong result of calculation in table with function SUM(LEFT)
This bug follows from bug 122648
https://support.office.com/en-us/article/sum-a-column-or-row-of-numbers-in-a-table-2e373a5f-2d8a-478a-9b85-275c8668bebb

Steps to Reproduce:
1. Open file DOCX from attach
2. See to result in column "Sum". It's null instead 37


Actual Results:
Writer shows incorrect result in table

Expected Results:
Writer shows correct result in table


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-01-15 08:47:47 UTC
Created attachment 148324 [details]
Example with table and function SUM(LEFT)
Comment 2 Roman Kuznetsov 2019-01-15 09:13:17 UTC
QA, please don't close it as dupe of bug 122648. 
IMHO, creating new formula with function SUM(LEFT) in Writer and opening of DOCX with SUM(LEFT) are different problem.
Comment 3 Durgapriyanka 2019-01-15 16:34:35 UTC
Thank you for reporting the bug. I can confirm this in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded
Comment 4 Xisco Faulí 2019-01-16 16:13:14 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c568eb7d3bb4584867f0a1f0a7965f73097f009b

author	Jean-Sebastien Bevilacqua <realitix@gmail.com>	2017-02-16 10:54:33 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-30 17:39:00 +0000
commit	c568eb7d3bb4584867f0a1f0a7965f73097f009b (patch)
tree	ea7e6fb1e0d77369a90bc69dd8756f589bb352e4
parent	53c2507bf97867011fd2bfbbac6c86b7fc494338 (diff)
tdf#105975 Add Formula field parsing (docx) in SWriter

Bisected with: bibisect-linux-64-5.4

Adding Cc: to Jean-Sebastien Bevilacqua
Comment 5 Xisco Faulí 2019-01-16 16:27:26 UTC
@László Németh, since you fixed bug 122224 I thought you might be interested in this issue...
Comment 6 Timur 2019-02-12 10:29:07 UTC
*** Bug 123392 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2019-02-12 10:34:12 UTC
It can be closed as a dupe of bug 123355, which covers all left/right/above/below cases...

*** This bug has been marked as a duplicate of bug 123355 ***