Bug Hunting Session
Bug 122730 - Screen rendering is still annoying
Summary: Screen rendering is still annoying
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-15 11:46 UTC by Karsten
Modified: 2019-01-16 13:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karsten 2019-01-15 11:46:05 UTC
Description:
The feeling is that the bad rendering is more and more annoying.
Specially working in Calc you get crazy with frames that have a different thickness.
On the screen you can't differ frames with different thickness.
In the preview lines of the same thickness are rendered random.
When printing often frames are not closed.

This problems exists for a really long time with no sufficient answer.
https://ask.libreoffice.org/en/question/45320/why-does-the-issue-of-on-screen-rendering-corruption-persist-after-so-long/

https://bugs.documentfoundation.org/show_bug.cgi?id=58358
https://bugs.documentfoundation.org/show_bug.cgi?id=113645

This simply MUST be fixed!

Actual Results:
Miserable screen rendering

Expected Results:
Usable screen rendering


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Oliver Brinzing 2019-01-15 18:02:46 UTC Comment hidden (obsolete)
Comment 2 Oliver Brinzing 2019-01-15 18:05:47 UTC Comment hidden (obsolete)
Comment 3 Karsten 2019-01-16 09:52:58 UTC
Please - i don't want to start a discussion like in ask.libreoffice.org.

I only want to say that i WANT to work with Libreoffice and i started to do it many years ago with Star-Office.

But it is a BASIC thing that you don't have to struggle permanently with screen artefacts and different output on the printer on different PC's.

Yesterday i installed Openoffice 4.1.6 and there are no screen artefacts - why this had been lost?
Comment 4 Telesto 2019-01-16 10:32:47 UTC
@Karsten
Thanks for the bug report. However it isn't really helpful. Please be really specific about the issue (or issues) you're experiencing. Ideally with a sample file and/or a screencast/screenshot. And please report separate issues in separate bug reports.

Don't expect people to know what you mean. Be as precise as possible.

Anyway. I think you're reporting to bugs here:
1. It this about zooming & cell borders? Or something else
2. Cell borders not being closed when printing

The second bug might be fixed in LibreOffice 6.1.4.2 (if I remember it correctly). So I would advise you to update. LibreOffice 6.0.7.3 won't get any updates as far I know.
Comment 5 Karsten 2019-01-16 11:05:05 UTC
Sorry - but you only distract from problems that have not been solved for many years.

There are enough open bugs like https://bugs.documentfoundation.org/show_bug.cgi?id=122457

That's the reason why there are only older versions of Libreoffice in the stable distributions like:
https://packages.debian.org/search?keywords=libreoffice&searchon=names&suite=stable&section=all

And i can tell you that this version 5.2.7 is not running sufficient.
I'd tried every update, but at least it is working more bad then better with any newer version.

So this really old version of Openoffice is the only solution?
Back to the roots, because fundamental functionality is lost?

Please - i don't want to attack you!
I just want you - the developers - to accept that some basic things went really wrong.
I WANT to work with Libreoffice because I LOVE IT!
But it is not possible any more when the rendering results on the screen and in printing are such bad.
Comment 6 Caolán McNamara 2019-01-16 11:21:01 UTC
please stop spamming bugzilla linking everything to this bug. This bug is vague and non-specific.
Comment 7 Buovjaga 2019-01-16 11:33:44 UTC
You link to bug 58358, which is reported as solved since 5.4. OpenGL was mixed to the report at a later point (off-topic).

You link to bug 122457 and also comment there, but do not provide any information on your hardware.

It is known Linux with OpenGL has problems. It has its own meta bug 97937.

Closing.

If you want to work with us, you can do this: https://wiki.documentfoundation.org/QA/GetInvolved#Quick_start_guide_for_beginners
Comment 8 Karsten 2019-01-16 11:35:59 UTC
Closing and ignoring will not solve this basic problem!
Comment 9 Buovjaga 2019-01-16 11:36:53 UTC
(In reply to Karsten from comment #8)
> Closing and ignoring will not solve this basic problem!

There is nothing of substance in this report, so nothing to ignore either. Please do not change the status.
Comment 10 Karsten 2019-01-16 12:16:44 UTC
It makes no sense to add more infos, because every bug with such an content is handled like this one in the same way.

At least it is not fixed, because the reason is a bad rendering engine.
There can be found hints that the rendering engine has changed with Libreoffice 5.3.
So version 5.2.7 is the last choice

https://www.reddit.com/r/linux/comments/9p7yg6/is_it_just_me_or_has_libre_office_writer_always/

I don't know why the engine have been changed?
Which rendering engine has been used in Openoffice - this is working perfect!
Comment 11 Buovjaga 2019-01-16 12:38:44 UTC
(In reply to Karsten from comment #10)
> It makes no sense to add more infos, because every bug with such an content
> is handled like this one in the same way.

No reason for conspiracy theories. There is no secret bias towards ignoring such issues. All lack of action is due to lack of resources.

> At least it is not fixed, because the reason is a bad rendering engine.
> There can be found hints that the rendering engine has changed with
> Libreoffice 5.3.

OpenGL as an option was introduced in 5.0. You are free to not use it: Tools - Options - LibreOffice - View - Use OpenGL for all rendering
Comment 12 Telesto 2019-01-16 13:20:52 UTC
(In reply to Buovjaga from comment #11)
> (In reply to Karsten from comment #10)
> > It makes no sense to add more infos, because every bug with such an content
> > is handled like this one in the same way.
> 
> No reason for conspiracy theories. There is no secret bias towards ignoring
> such issues. All lack of action is due to lack of resources.

Or a lacking a proper report at the proper place. This looks like an issue https://pasteboard.co/HJ1YY5d.png (https://www.reddit.com/r/linux/comments/9p7yg6/is_it_just_me_or_has_libre_office_writer_always/)

However the reporter decided to not report it here (see https://www.reddit.com/r/linux/comments/9p7yg6/is_it_just_me_or_has_libre_office_writer_always/e80qvgh) because of his misinterpretation and assumptions

The bug 58358 is closed as WFM because it isn't reproducible anymore (I can't). If the same - or similar - issue is present again new report should be created. 
A report doesn't mean it will be fixed right away of course. Yes, it can take a long long time to be fixed, if ever (All lack of action is due to lack of resources...). However, without a proper report it won't be fixed for sure...

Anyway referencing all sorts of sites isn't helpful. Describe you're own problem and illustrate it with a sample file/ screencast. For further reading: https://wiki.documentfoundation.org/QA/BugReport (Caption "Good Reports")