Bug Hunting Session
Bug 122736 - Crash swlo!SwFrame::IsLeaveUpperAllowed
Summary: Crash swlo!SwFrame::IsLeaveUpperAllowed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
: 121550 (view as bug list)
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2019-01-15 15:51 UTC by Telesto
Modified: 2019-07-19 18:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
BT without symbols (4.06 KB, text/plain)
2019-01-15 15:51 UTC, Telesto
Details
STR Screencast (4.97 MB, video/mp4)
2019-01-15 17:58 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-15 15:51:20 UTC
Description:
Follow up on bug 119126 

Steps to Reproduce:
1. Open attachment 147138 [details]
2. CTRL+A + CTRL+C
3. CTRL+N
4. CTRL+V
5. Scroll up to second page (with yellow marking)
6. Paste the empty paragraph
7. Play with CTRL+Z CTRL+Y (undo few times, redo)

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 61778fd20395794d2de3b52d60dcc65083aecd93
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2019-01-15 15:51:53 UTC
Created attachment 148337 [details]
BT without symbols
Comment 2 Dieter Praas 2019-01-15 17:52:02 UTC
(In reply to Telesto from comment #0)
> 6. Paste the empty paragraph

Not clear to me, what empty paragraph and where I should paste it.
Comment 3 Telesto 2019-01-15 17:58:42 UTC
Created attachment 148345 [details]
STR Screencast

Mostly I get a crash reporter instead of hard close...
Comment 4 MM 2019-01-15 21:54:49 UTC
Confirmed on windows 7 x64 with Version: 6.0.7.3 (x64)
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU threads: 3; OS: Windows 6.1; UI render: default

> 6. Paste the empty paragraph

Should be, Paste (CTRL - V) into the empty space, below the yellow x's

Fatal Error - 'Access Violation - No RTTI Data!'
crashreport.libreoffice.org/stats/crash_details/ccd4f895-81f2-43cc-b573-9e153eb10864

Confirmed on mint 19.1 with Version: 6.3.0.0.alpha0+
Build ID: 35ea8fc24ae749b8a87b7ddb5df22ecc4f58cfd3
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-15_01:16:13
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Telesto 2019-01-15 22:06:35 UTC
@Xisco
Follow up for bug 119126.
Comment 6 Julien Nabet 2019-01-17 08:41:18 UTC
Just when opening the file from tdf#119126, I got:
warn:legacy.osl:9604:9604:sw/source/core/layout/calcmove.cxx:296: :-( Layout unstable (this not found)
and
endless this one:
warn:legacy.osl:9604:9604:sw/source/core/layout/tabfrm.cxx:2632: debug assertion: <SwTabFrame::MakeAll()> - format of table lowers suppressed by fix i44910

I stopped the test there, no need to keep on if there are still problems like this.
Comment 7 Telesto 2019-01-18 14:18:42 UTC
(In reply to MM from comment #4)
> Confirmed on windows 7 x64 with Version: 6.0.7.3 (x64)
> Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
> CPU threads: 3; OS: Windows 6.1; UI render: default

The reproduced crash is likely due to bug 119126 (when using LibO 6.0.7.3). On the other hand.. I have had a few RTTI crashes with 6.3 also.. So it might be that footnote issue only made the problem more frequently appear..
Comment 8 Telesto 2019-02-03 15:30:17 UTC
*** Bug 121550 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2019-05-24 19:17:05 UTC
@Michael
Thanks for all the work on the mitigating table lay-outing crashes.. 
This one is still reproducible. And yes, the table is a smoking ruin.. I'm aware of that

1. Open attachment 147138 [details]
2. CTRL+A + CTRL+C
3. CTRL+N
4. CTRL+V
5. CTRL+V -> Crash

Version: 6.3.0.0.alpha1+
Build ID: f5b9590fc06811a9dff550c6998d1d1088507e23
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 10 Xisco Faulí 2019-05-27 11:23:13 UTC
(In reply to Telesto from comment #9)
> @Michael
> Thanks for all the work on the mitigating table lay-outing crashes.. 
> This one is still reproducible. And yes, the table is a smoking ruin.. I'm
> aware of that
> 
> 1. Open attachment 147138 [details]
> 2. CTRL+A + CTRL+C
> 3. CTRL+N
> 4. CTRL+V
> 5. CTRL+V -> Crash
> 
> Version: 6.3.0.0.alpha1+
> Build ID: f5b9590fc06811a9dff550c6998d1d1088507e23
> CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
> Locale: nl-NL (nl_NL); UI-Language: en-US
> Calc: CL

I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 26e85974a0287ab5869e7ff0145a66b853d66a02
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

nor in

Version: 6.3.0.0.alpha1+
Build ID: 53325b40b557cc84d8d21c1baa0ef8d3bfc00ab8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Telesto 2019-05-27 19:17:56 UTC
(In reply to Xisco Faulí from comment #10)
> (In reply to Telesto from comment #9)
> > @Michael
> > Thanks for all the work on the mitigating table lay-outing crashes.. 
> > This one is still reproducible. And yes, the table is a smoking ruin.. I'm
> > aware of that
> > 
> > 1. Open attachment 147138 [details]
> > 2. CTRL+A + CTRL+C
> > 3. CTRL+N
> > 4. CTRL+V
> > 5. CTRL+V -> Crash
> > 

Repro with
Version: 6.3.0.0.alpha1+
Build ID: 63b39fe87644587210214198fb67d6b3fb3343c5
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-05-27_01:42:59
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: CL
Comment 12 Telesto 2019-06-02 13:18:12 UTC
I'm still able to repro comment 0 & comment 9
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 93477d1a963e38e3319013e43835a8ffef200972
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-02_10:16:52
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: threaded
Comment 13 Dieter Praas 2019-06-02 14:49:44 UTC
Yes, crash in

Version: 6.3.0.0.beta1 (x64)
Build-ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: en-US (de_DE); UI-Sprache: de-DE
Calc: threaded

but not in

Version: 6.2.4.2 (x64)
Build-ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 14 Telesto 2019-07-19 18:11:57 UTC
I'm not able to repro & I expect this to be fixed anyhow (after all the fixes of M. Stahl)
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 2f2f4767089512c34514896bc37823f9310e9dd4
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-10_00:49:53
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL