Bug 122777 - Impress: "Slides" pane: Can't select slide, if tooltip shown
Summary: Impress: "Slides" pane: Can't select slide, if tooltip shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Page-Pane
  Show dependency treegraph
 
Reported: 2019-01-17 07:05 UTC by DarkTrick
Modified: 2021-12-03 22:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
video showing working on the same version on linux - cant confirm - (222.35 KB, video/mp4)
2019-01-17 20:43 UTC, BogdanB
Details
New video with tooltip running away from mouse (1.08 MB, video/mp4)
2019-01-22 19:10 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DarkTrick 2019-01-17 07:05:01 UTC
Description:
It's not possible to select a slide through the "Slide bubble", that appears, if the mouse cursor is hovering over a slide. 


I recorded a short clip showing the behaviour:
https://youtu.be/nwMGhc5nDdE
(unfortunately my mic wasn't recorded, so you don't here, that I clicked the mouse button about 200 times )

Steps to Reproduce:
Current behaviour:
===================

1. Create a presentation.
2. Make the "slides" sidebar being shown.
3. Insert so many slides to make them exceed the screens vertical (e.g. 20).
4. Select slide number 1.
5. Move the cursor the last slide shown on the screen.
6. A bubble will appear like ("Slide 7").
7. Now try to select the slide through the bubble.



Actual Results:
8. You cannot select the slide through the bubble.

Expected Results:
@8. Selecting a slide through a bubble is possible


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Happens with and without hardware acceleration (probably OpenGL)
Comment 1 Durgapriyanka 2019-01-17 17:53:19 UTC
Thank you for reporting the bug. I cannot confirm this because the "Slide Bubble" doesn't appear in my slide.

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 BogdanB 2019-01-17 20:43:08 UTC
Created attachment 148409 [details]
video showing working on the same version on linux - cant confirm -

I tested on 
Versiune: 6.0.7.3
Identificator construire: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
Fire CPU: 4; OS: Linux 4.15; Redare UI: implicit; VCL: gtk2; 
Setări regionale: ro-RO (ro_RO.UTF-8); Calc: group

See the video. I have the same version and also linux, but in my case it is working.
Comment 3 DarkTrick 2019-01-19 08:54:35 UTC
In the video you're only hovering over the slides in the middle of the screen. Try to over over slide 8. Your tooltip might then appear below the mouse pointer.
Comment 4 BogdanB 2019-01-22 19:09:30 UTC
My tooltip is little in my case, maybe is up to the OS you use or settings...
But in my case the tooltip is runnig from my mouse... See the left bottom corner...
Comment 5 BogdanB 2019-01-22 19:10:01 UTC
Created attachment 148528 [details]
New video with tooltip running away from mouse
Comment 6 DarkTrick 2019-01-23 10:25:26 UTC
Comment on attachment 148528 [details]
New video with tooltip running away from mouse

indeed.

I'm on XUbuntu. So I guess this is rather a bug for XFCE
Comment 7 Buovjaga 2019-01-26 20:18:32 UTC
As there is suspicion OpenGL rendering is in use, please copy and paste here the contents of your Help - About.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 8 DarkTrick 2019-01-28 23:53:20 UTC
Problem also appears without OpenGL

content of About:
---------------------------------------------
Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
---------------------------------------------
Comment 9 edera 2019-09-25 08:22:34 UTC
Confirmed,
the tooltip of the "slides" panel get in the way.
Clicking in the middle of the slide thumbnail
should select that slide.
Instead the click is swallowed by the tooltip.
Version: 6.2.5.2
Build ID: 20(Build:2)
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: kde5

It necessary either to click outside the tooltip (not practical),
or use keyboard.
Comment 10 edera 2019-09-25 08:31:33 UTC
To be more precise: 
The issue appears here because the tooltip is not below the slide thumbnail,
but centered on it.
Apparently that depends on the environment.
Comment 11 edera 2019-09-25 13:16:29 UTC
They solved a similar issue in calc:
https://bugs.documentfoundation.org/show_bug.cgi?id=123779#c6
that might be relevant ?
Comment 12 QA Administrators 2021-09-25 03:39:24 UTC Comment hidden (obsolete)
Comment 13 Ezinne 2021-12-03 22:02:33 UTC
No longer reproducible in:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: d272bf4f8f3a083b8c37f7b10f89cd2bf76b7d21
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded