Bug 122779 - FILEOPEN (BASE) Connection to Oracle DB via ODBC ends in [ODBC][ORACLE] Optional Feature not implemented
Summary: FILEOPEN (BASE) Connection to Oracle DB via ODBC ends in [ODBC][ORACLE] Optio...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-01-17 07:53 UTC by Thierry Menigoz
Modified: 2019-07-23 07:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen captures of error and LibO "About" (2.54 MB, application/vnd.oasis.opendocument.text)
2019-01-17 07:53 UTC, Thierry Menigoz
Details
Screen captures of Oracle ODBC Driver parameters (97.20 KB, application/vnd.oasis.opendocument.text)
2019-01-17 08:21 UTC, Thierry Menigoz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Menigoz 2019-01-17 07:53:34 UTC
Created attachment 148384 [details]
Screen captures of error and LibO "About"

I had been using for a long time a connection to Oracle Database data through Base using the Oracle ODBC Driver and this was perfectly working until I updated to LibreOffice 6.2 (Orignally 6.2.1 and now 6.2.2 but does not change result).
I tried to return to LibreOffice 6.1.4 (before installing 6.2, I was running 6.1.2) but, unfortunately any call to display a table, a view or a query ends up with message [ODBC][ORACLE] Optional Feature not implemented.
Error displayed is HYC00.
I tried to reset my UserProfile but no improvement.

I underline that the ODBC driver is fully operational when used from other Windows apllications like MS Excel or MS Access.

I tried to re-create a new Oracle ODBC linkage and connect through it but same message appear. Curiously, when testing connection from my Base File properties menu, test is OK.
Comment 1 Thierry Menigoz 2019-01-17 08:21:02 UTC
Created attachment 148386 [details]
Screen captures of Oracle ODBC Driver parameters

I forgot to highlight that, for compatibility reasons with our ERP system, Oracle Driver is a 32-bit version and i always install LibreOffice in 32-bit version as the 64-bit does not support 32-bit drivers
Comment 2 Julien Nabet 2019-01-17 08:36:57 UTC
There's no 6.2.1 or 6.2.2 yet.

Just to be sure, there's no problem with 6.1.2 but you've got problem with 6.1.4 and 6.2.0?
It could be interesting to have the result with 6.1.3 so we'd know exactly from which LO version the pb appears.
Comment 3 Thierry Menigoz 2019-01-17 11:56:39 UTC
Sorry, my mistake, last updates were 6.2.0.1 & 6.2.0.2 :(

I downgraded to version 6.1.2.1 from my original sources refreshing to a new User Profile through the FailSafe menu and I confirm that I have not the above mentioned error launching display of data in Tables, Views or Queries.

I then upgraded to version 6.1.3 and error re-appear with this version ...
Comment 4 Julien Nabet 2019-01-17 18:13:52 UTC
Ok so the earliest version is 6.1.3.2 and it's a regression.
Comment 5 Xisco Faulí 2019-03-21 12:53:15 UTC
Hello Thierry,
LibreOffice 6.2.2.2 is going to be released today, could you please try again
with this version to see if the problem has been resolved meanwhile? Thanks in
advance
Comment 6 Thierry Menigoz 2019-03-21 13:30:02 UTC
Dear Xisco,

I recently installed in parallel Version 6.2.2.1 and bug is still present in this version.
I will try with version 6.2.2.2 when available and keep you posted.
Comment 7 Thierry Menigoz 2019-03-25 09:59:30 UTC
I did a fresh install of version 6.2.2.2 and still get the same error # HYC00 - [Oracle][ODBC]Optional feature not implemented.

As before, list of Oracle Schemes, Tables or Views is displayed but error happen when I try to display data of these Tables or Views or Queries registered in a LibO Base file.
Note that all queries registered in the Base file are with the "Direct Execution of SQL Statement" feature enabled.
Comment 8 Thierry Menigoz 2019-07-23 07:30:22 UTC
I installed Version 6.3.0.1 - 32 bits and error do not appear anymore!
I am again able to display Table data, views or result of queries.

Therefore, I change status to "Resolved" / "Fixed"
Comment 9 Robert Großkopf 2019-07-23 07:48:02 UTC
There hasn't been submitted a fix for this bug. Seems the bug has been gone without fixing. So I changed to "Worksforme"