Bug 122821 - Crash: sclo!ScDocOptions::GetDate
Summary: Crash: sclo!ScDocOptions::GetDate
Status: RESOLVED DUPLICATE of bug 121949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2019-01-19 23:12 UTC by Telesto
Modified: 2019-03-12 17:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (9.27 KB, text/plain)
2019-01-20 09:48 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-19 23:12:09 UTC
Description:
Crash: sclo!ScDocOptions::GetDate

Steps to Reproduce:
1. Open Calc
2. Select A1 & B2 (by CTRL+CLICK)
3. CTRL+C -> CRASH

Actual Results:
Crash

Expected Results:
no crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Julien Nabet 2019-01-20 09:48:11 UTC
Created attachment 148448 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated 2 days ago + gtk3, I could reproduce this.
Comment 2 Julien Nabet 2019-01-20 09:49:07 UTC
More precisely, I had an assertion.

Eike: thought you might be interested in this one.
Comment 3 Julien Nabet 2019-01-20 10:04:42 UTC
Investigating the bt, I found that https://cgit.freedesktop.org/libreoffice/core/commit/?id=4ddd6f329163cbac5ff31e51a5b028d8eeedadd2

I tried this naive patch locally:
diff --git a/sc/source/core/data/documen2.cxx b/sc/source/core/data/documen2.cxx
index ebcae2c95774..a2b6287aabc3 100644
--- a/sc/source/core/data/documen2.cxx
+++ b/sc/source/core/data/documen2.cxx
@@ -1163,7 +1163,7 @@ void ScDocument::RemoveLookupCache( ScLookupCache & rCache )
 void ScDocument::ClearLookupCaches()
 {
     assert(!IsThreadedGroupCalcInProgress());
-    DELETEZ(GetNonThreadedContext().mScLookupCache);
+    //DELETEZ(GetNonThreadedContext().mScLookupCache);
     // Clear lookup cache in all interpreter-contexts in the (threaded/non-threaded) pools.
     ScInterpreterContextPool::ClearLookupCaches();
 }
I don't reproduce the assert and got no crash.

Dennis: thought you might have some opinion here.
Comment 4 Julien Nabet 2019-01-20 10:05:57 UTC
Meanwhile, let's put this one to NEW even if crash and assert are different.
Comment 5 Dennis Francis 2019-01-20 10:14:12 UTC
I'll investigate. Thanks.
Comment 6 Xisco Faulí 2019-01-20 16:36:13 UTC
This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák ; Could you possibly take a look at this one?
Thanks

a79e88101e6ecc177dd9de08f7c5fa0fd4a9843b is the first bad commit
commit a79e88101e6ecc177dd9de08f7c5fa0fd4a9843b
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Oct 10 13:22:44 2018 +0200

    source sha:79449d73900d7a9bf061244d76f5f8eecc441198

author	Luboš Luňák <l.lunak@collabora.com>	2018-10-01 14:26:57 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2018-10-10 13:01:59 +0200
commit	79449d73900d7a9bf061244d76f5f8eecc441198 (patch)
tree	e85f9bc29941cbf5e5ccb858ee4703ae67d00810
parent	b1721b04d8a921a69230927cd7995d8c5d8f5fe2 (diff)
make VLOOKUP in Calc thread-safe
Comment 7 Xisco Faulí 2019-01-20 16:37:31 UTC
This seems to be a duplicate of bug 121949
Comment 8 Xisco Faulí 2019-03-12 17:03:42 UTC
This issue has been fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b5c3f38cb8d4121e3303be362e0757d3d3431059.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 121949 ***