Bug 122863 - Date field values change in Base
Summary: Date field values change in Base
Status: RESOLVED DUPLICATE of bug 67763
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-21 19:00 UTC by Ken Gramm
Modified: 2019-01-22 09:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Gramm 2019-01-21 19:00:15 UTC
Description:
I have a simple DB in Base with three tables (called 2017, 2018, 2019).  All three have a single record for each day of the year and have a date field set as the key.  The date format is YYYY-MM-DD.  On four occasions over the last year, all of the values of the date field have shifted one day back. 

For example, two days ago, my first record in the table 2019 was 2019-01-01.  Today, it is 2018-12-31.  And all of the following entries are shifted too.  It is the same for the other two tables also.

No other data is changed.

The first couple of times it happened, all of the the data was in one large table and I manually corrected each line.  The third time, I copied out the data, edited it in Calc, and then imported it back into separate tables, one for each year.

The only thing that has happened to my machine lately is that I traveled to a different time zone (from US Central to US Mountain) and updated my clock to reflect the change.

Although I can't be certain, but I also traveled around the same time as the other issues.

Steps to Reproduce:
1. Create new table, set date field as the key, wait... (maybe change the time zone setting of computer).

Actual Results:
Date values shift one day back.

Expected Results:
Dates to be correct.


Reproducible: Sometimes


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group threaded
Comment 1 Ken Gramm 2019-01-21 19:03:31 UTC
To be clear about my time zone change, I traveled to a different time zone (-6:00 -> -7:00), updated my clock.  Then came back and corrected my clock again (-7:00 -> -6:00).
Comment 2 Ken Gramm 2019-01-21 19:04:17 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2019-01-21 19:10:39 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 4 Alex Thurgood 2019-01-22 09:07:33 UTC
@Ken :

Assuming you are using an embedded hsqldb database, this is a known lack of feature support in the timezone management within LOBase, see for example bug 67763

In particular, read Lionel's remarks in comment 1 of that bug under "Timezone"

*** This bug has been marked as a duplicate of bug 67763 ***
Comment 5 Alex Thurgood 2019-01-22 09:14:44 UTC
See also the description of current hsqldb behaviour in the opening description of bug 119675, the aim of which is to request, for the complete switch to default of embedded Firebird ODB files, a UI option to set the handling of date/time vaues.