Bug 122926 - FILEOPEN ODT Slower compared to the past
Summary: FILEOPEN ODT Slower compared to the past
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: File-Opening
  Show dependency treegraph
 
Reported: 2019-01-24 12:21 UTC by Telesto
Modified: 2019-04-02 12:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (39.57 KB, application/vnd.oasis.opendocument.text)
2019-01-24 12:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-24 12:21:52 UTC
Description:
File-opening ODT: slower compared to the past. 
Source: https://bz.apache.org/ooo/attachment.cgi?id=76640 
A modified one attached

Steps to Reproduce:
1. Open the attached file


Actual Results:
16 seconds or so

Expected Results:
4 seconds with 3.0.0


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2019-01-24 12:22:14 UTC
Created attachment 148596 [details]
Example file
Comment 2 Durgapriyanka 2019-01-24 17:24:25 UTC
It takes 35 seconds to open in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 3 Buovjaga 2019-01-27 19:32:22 UTC
Bibisected on Linux with 43max to https://gerrit.libreoffice.org/plugins/gitiles/core/+/14f124a5ef5c32bad765265d5a3f05290ccc6149%5E!/

Resolves: #i124338# assure sorted mark containers...

when updating <SwIndex> instances due to inserted characters

It is a commit picked from AOO in 2014.
Comment 4 Xisco Faulí 2019-03-28 14:43:53 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2019-03-28 14:47:49 UTC Comment hidden (obsolete)
Comment 6 Commit Notification 2019-04-01 17:00:00 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9634f5ee73e57e8cef75461316d5d45b06ee104f%5E%21

tdf#122926 FILEOPEN ODT Slower compared to the past

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Buovjaga 2019-04-01 19:07:07 UTC
I confirm the time went down.

6.2.2:
real    0m10,867s
user    0m10,050s
sys     0m0,352s

master with the above commit:
real    0m9,712s
user    0m9,238s
sys     0m0,456s

(both with gtk3)
Comment 8 Xisco Faulí 2019-04-01 21:50:38 UTC
(In reply to Xisco Faulí from comment #5)
> timing is shorter if I use gen
> 
> real	0m57,113s
> user	0m54,294s
> sys	0m0,599s

it seems the other day my computer was slow... I've just retested with the same version

real	0m19,941s
user	0m19,514s
sys	0m0,392s

while in master ( with noel's commit included ) it takes

real	0m16,490s
user	0m15,928s
sys	0m0,534s
Comment 9 Xisco Faulí 2019-04-02 08:27:01 UTC
With https://gerrit.libreoffice.org/#/c/70112/
it goes from

real	0m16,583s
user	0m15,149s
sys	0m0,518s

to

real	0m11,014s
user	0m10,588s
sys	0m0,357s

nice!!!
Comment 10 Commit Notification 2019-04-02 09:23:43 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ba748771cadb294d6af7b7c784c33ccf8632dff1%5E%21

tdf#122926 FILEOPEN ODT Slower compared to the past (part2)

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Buovjaga 2019-04-02 09:51:27 UTC
The latest commit shaved off over two seconds for me:
real    0m7,367s
user    0m6,702s
sys     0m0,506s
Comment 12 Commit Notification 2019-04-02 11:24:26 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3b518953a8141b0d5043c2f3996a92956fdc3a47%5E%21

tdf#122926: Use o3tl::sorted_vector in other similar places

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-04-02 12:15:16 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/8917f812cdf28d7ce8907d7a5971749c3ec8815d%5E%21

tdf#122926 FILEOPEN ODT Slower compared to the past

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.