Bug 122950 - Image -> Add Caption -> No description => Can't change caption instantly afterwards
Summary: Image -> Add Caption -> No description => Can't change caption instantly afte...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Caption
  Show dependency treegraph
 
Reported: 2019-01-25 10:06 UTC by DarkTrick
Modified: 2021-05-08 04:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DarkTrick 2019-01-25 10:06:12 UTC
Description:
Here is an example video:
https://youtu.be/yP8dTIHZB8A?t=16

After inserting a caption without description it's not possible to click the description part in the document to add a description. You first need to focus some other object.

Steps to Reproduce:
1. Add Image
2. Add Caption (leave description blank)
3. OK
4. Caption is inserted
5. Now try to add a description behind the [Category][Number]. 
6. You cant set the keyboard cursor there because the image/frage has a strange focus

Actual Results:
Step 6 is unexpected

Expected Results:
@6: Clicking inside the frame will change the focus from frame to text input.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Workaround:
Click somewhere else inside the document first and then try to change the caption and it's going well.
Comment 1 Dieter 2019-01-25 12:38:40 UTC
If you click very close behind the Number, the number is highlighted. but if you click. But if you click at the formatting mark behind the number, the cursor appears. For me NOTABUG.
Do you get the same result? Do you want to treat it as a bug?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' or to RESOLVED NOTABUG.
Comment 2 DarkTrick 2019-01-26 01:18:14 UTC
> Do you get the same result? 
For me, no matter where I click the cursor does not appear.

-------------
Extra information:
This always happens, when the frame (not picture) is selected. Therefore the following will trigger it as well:

1. Insert an image 
2. Add caption (insert random caption)
3. Focus something else inside writer
4. Click on the frame (set the focus to the frame)
5. In this state you can't click the caption text to change it ( as described above)
-------------

>  Do you want to treat it as a bug?

I became unsure, if it's a bug-report or a suggestion. This definitely needs specification on how the frame should behave to be more intuitively. 

I would say:
This is unexpected behaviour and can decrease good user experience. Therefore imo the behaviour should be changed.

That being said, which would you prefer?
Comment 3 Dieter 2019-01-29 19:57:16 UTC
I confirm the behaviour with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

Actual result:
If you have selcted the frame and
- click outside the frame => the cursor appears
- click within the image => the image is selected
- click once wihin the caption => nothing happens

Expected result:
One click within the caption => cursor should appear

I'm also unsecure, if this is a bug or an enhancement, so I add design team in cc:
Comment 4 Heiko Tietze 2019-01-30 13:15:02 UTC
It's by design that we keep the focus when functions are applied to objects. However, it's also expected to change the (empty) caption immediately. So what we could do is to not switch to the frame and keep the focus on the image/chart/object. Or alternatively we could go into the caption edit mode when it is empty.

=> needsDevAdvice (might be an easy hack)
Comment 5 DarkTrick 2019-01-31 08:56:43 UTC
My idea:
 - Recognize a click (button-down, button-up) at the caption area.

Reason:
 - This behaviour is congruent to the behaviour for clicking the picture.
   ( Select frame -> Click the picture -> Picture gets focus )
Comment 6 Dieter 2021-05-08 04:38:25 UTC
Still present in

Version: 7.1.3.2 (x64) / LibreOffice Community
Build ID: 47f78053abe362b9384784d31a6e56f8511eb1c1
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL