Download it now!
Bug 123076 - New print dialog: Page Format is always A4
Summary: New print dialog: Page Format is always A4
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.3.5 target:6.4.0.1
Keywords:
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2019-01-30 23:49 UTC by Xisco Faulí
Modified: 2020-07-08 13:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Dummy text on DL sized page (408.00 KB, image/png)
2019-05-08 11:45 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-01-30 23:49:19 UTC
Steps to reproduce:
1. Open Writer
2. Go to Format - Page -> Change Format to something different from A4 ( e.g. A6 )
3. Go to File - Print

Behaviour: On top of print preview it says A4
Comment 1 himajin100000 2019-01-31 00:35:58 UTC
I believe that page style is not in what paper you print with.
Print preview opens first with the "default paper for the printer", and the paper you use can be changed via Page Layout->Paper size on the right side of the dialog.

On my windows 10 machine, I can change my default paper via:
control panel->Devices and Printers->(select my printer)->right click->Printer's preference

Quiz:
I have Brother's printer DCP-J973N, and this printer can print only up to A4, but I have a friend who has a printer capable of printing A3, and I want to make a file for him. Which one should I change?
Comment 2 Xisco Faulí 2019-03-13 19:08:13 UTC
ok, let's close it as RESOLVED NOTABUG
Comment 3 Thomas Lendo 2019-05-06 05:44:00 UTC
I want reopen this bug because I don't understand the intention of such a behavior. The print preview should always and automatically show the paper size that the user has chosen in the page style if it fits to the possibilities of the chosen printer.

Now, the print preview ALWAYS shows A4 paper size regardless of what the paper size of the page style is (for example: A3) and regardless of what the printer can print in reality (for example: A3 is also possible).

Therefore this is a bug.

It's bad usability to force the user to change something in the print dialog what was defined well in page style and in printer options. If both are compatible, nothing should be done manually by the user anyway.

The old print dialog behaves as described by me.


Steps to reproduce:
1. Open Writer.
2. Change page style in Format > Page... > Page to a format that your default printer of your operating system can print but NOT A4 (or what default paper size you have in your locale).
3. Open the print dialog with File > Print.

Actual result:
Print preview in the print dialog shows an A4 page regardless of that your page style format is available in the paper size list box at the right half of the print dialog.

Expected result:
If the selected printer can print your chosen page format in the page style dialog, this page format should be automatically shown in the preview and chosen in the paper size list box.
Comment 4 Heiko Tietze 2019-05-08 11:45:49 UTC
Created attachment 151241 [details]
Dummy text on DL sized page

We talk about Print > Preview, not Print Preview. The paper size depend on what is set at Format > Page, defaulting to A4 when the locale is metric or letter in case of English (USA), for example. The preview says A4 but shows the actual value and when explicitly set to A4 it updates the preview. => bug
Comment 5 himajin100000 2019-07-10 16:44:54 UTC
https://opengrok.libreoffice.org/xref/core/vcl/source/window/printdlg.cxx?r=45839115#953

just a guess: mePaper is not changed since its initial value?
Comment 6 Commit Notification 2019-12-12 13:47:02 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/562c30d5ad142fcdc77be6125fdac6d48b782fd7

tdf#123076 Get paper size for print preview

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-12-12 16:48:45 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/96bf3c26037c520817fc256d0c942bc78eef3472

tdf#123076 Get paper size for print preview

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-12-12 16:48:57 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8659c42c4a016722cf6418e6ff1cd34bc5bdf88e

tdf#123076 Get paper size for print preview

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.