Bug 123077 - gtk3_kde5, kde5: Crash when minimizing file save dialog
Summary: gtk3_kde5, kde5: Crash when minimizing file save dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.6
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-31 00:06 UTC by Michael Weghorn
Modified: 2019-02-01 08:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace for the case where the kde5 VCL plugin is used (12.02 KB, text/plain)
2019-01-31 00:12 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2019-01-31 00:06:57 UTC
from Debian bug report https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920859 against the 'libreoffice-kde5' Debian package that provides the gtk3_kde5 VCL plugin:

> Package: libreoffice-kde5
> Version: 1:6.1.5~rc1-2
> Severity: normal
>
> Dear Maintainer,
>
> LibreOffice crashes when minimizing the file save dialog. Steps to reproduce:
>
> 1. Start LibreOffice
> 2. File -> New -> Text Document (or other)
> 3. File -> Save As... - save dialog appears
> 4. Minimize dialog window - dialog and LibreOffice windows get minimized
> 5. Maximize windows again
>
> Dialog window crashes, KDE crash pop-up menu appears
> "lo_kde5filepicker Closed Unexpectedly". LibreOffice remains blocked and
> can only be killed.
>
> Always reproducable in testing & sid with version
> 1:6.1.5~rc1-2 and in version 1:6.2.0~rc2-1 from experimental
> [...]
Comment 1 Michael Weghorn 2019-01-31 00:10:13 UTC
I can reproduce with:

Version: 6.3.0.0.alpha0+
Build ID: eaec995a96b41963ae9e5156b6c5c7ac022f9a55
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

and a crash also happens for the kde5 VCL plugin:

Version: 6.3.0.0.alpha0+
Build ID: eaec995a96b41963ae9e5156b6c5c7ac022f9a55
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Since the initial reporter is another one (s. Debian bug), I'm therefore self-confirming.
Comment 2 Michael Weghorn 2019-01-31 00:12:37 UTC
Created attachment 148784 [details]
backtrace for the case where the kde5 VCL plugin is used
Comment 4 Commit Notification 2019-01-31 10:53:34 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/68b15aee96abf5cd2179009424ab6a0229b67756%5E%21

tdf#123077 kde5: Set KFileWidget's custom widget only once

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-01-31 11:30:53 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/30cc54a4532a732a0cf6dfe9943521978ff7292f%5E%21

tdf#123077 gtk3_kde5: Set KFileWidget's custom widget only once

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Weghorn 2019-01-31 11:37:21 UTC
Fixed on master now.

Pending backports:

* 6.2:
  * https://gerrit.libreoffice.org/#/c/67205
  * https://gerrit.libreoffice.org/#/c/67203

* 6.1 (which has no kde5): https://gerrit.libreoffice.org/#/c/67204
Comment 7 Commit Notification 2019-01-31 16:25:18 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c7b13a768d5185ba7e57c73062d97d4bdbcaa3e5%5E%21

tdf#123077 kde5: Set KFileWidget's custom widget only once

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-01-31 20:00:23 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/7b54f3db98e96231fc9f16429f325cdb1f37498c%5E%21

tdf#123077 gtk3_kde5: Set KFileWidget's custom widget only once

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-02-01 08:33:17 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/f8bef86cc88e99b32e223b2bd675959c6d8e46ad%5E%21

tdf#123077 gtk3_kde5: Set KFileWidget's custom widget only once

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.