Bug Hunting Session
Bug 123145 - Provide a "Remove" button for Java Paths
Summary: Provide a "Remove" button for Java Paths
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-03 16:51 UTC by himajin100000
Modified: 2019-03-22 08:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description himajin100000 2019-02-03 16:51:12 UTC
Description:
see steps to reproduce

Steps to Reproduce:
1. Tools->Options
2. LibreOfficeDev->Advanced
3. Look at the Buttons on the right side.

Actual Results:
No Remove button, Only Add button exists

Expected Results:
Add button and Remove button exist, so that I can easily find the item I want to select even when I added too many paths


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-03-21 16:29:43 UTC
This does not make sense. The selection is made/indicated by radio button. If you have multiple valid paths to installed JRE or OpenJDK they all will list (the dialog parses them from system).

A "remove" path button is not necessary.

IMHO=> WF
Comment 2 himajin100000 2019-03-21 16:37:29 UTC
I sometimes manually add various versions of JDKs from multiple vendors provided in zip format. 

I noticed that I have added too many JDKs and I thought this might cause difficulty in finding the one I want, and that's the reason I want this "Remove button".
Comment 3 Heiko Tietze 2019-03-22 08:19:20 UTC
It's like fonts, you can add a gazillion to your system and need to get rid of it somehow. But unless fonts, which usage might depend on app, Java frameworks are generic. So you better clean up your system than tweak it in an app. Last but not least I doubt you have so many (>>20) that it requires management.

WF in agreement with Stuart.