Bug 123155 - Spelling is Broken
Summary: Spelling is Broken
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2019-02-03 23:52 UTC by James
Modified: 2019-08-19 07:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
spell check broken issue in version:6.3.0.0.alpha0+ (157.22 KB, image/jpeg)
2019-02-06 01:22 UTC, anugo
Details
specll check works - screenshot from LO 6.3+.jpg (72.43 KB, image/jpeg)
2019-02-07 15:09 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James 2019-02-03 23:52:24 UTC
Description:
The little Red Underline when a word is misspelled is broken to all hell. While typing a word before done, it will suggest the correct word as a pop up, but if you misspell one, it is broken, even right click will not work. Yes, I searched help, to turn that feature on (well it just quit whatever it wasn't even turned off). and guess what? Still a big fat broken bug!!!!! Thanks a lot you bugs, you are bugging me! Yeah, looks like I can update this P.O.S. (doesn't stand for point of sale), like I'm so sure all these fucking bugs just ran out on the update. Thanks for making this a serious derailed process to report, to search, to make an account, and all this nonsense because the document I'm working on is still not getting done faster. I can copy and paste it into this box and when you smisheti a word (HAHAHA), guess what it red underlines it on this html driven web page and allows a right click option to fix.... so why is your sophisticated software failing me while trying to write a business proposal? All of this is going to end up uninstalled and and redone in google documents probably. Not recognizing the value in the program, other than ease of familiarity. OK thanks for the bug, I'm bugged, this bug report bugged you I'm sure, but I just lost so much time on this whole bug report even. Thanks, I am just in a weird mood, I do not really mean to offend. If it helps I'm on a lenovo windows 10 OS computer. Thanks!

Steps to Reproduce:
1. misspell a word
2. Watch Office Libre be a piece of shit
3. YOu fucking hit a back button try again because you didn't pick a fucking component. What evil realm of hell did you find the jerk wads who made this?

Actual Results:
ACTUAL RESULT? STUPID BROKEN SHIT of your mother who pooped you out and forgot to flush, so Satan picked you out of the toilet and thought he would teach you the absolute most evil way to program anything ever in the history of computers.

Expected Results:
SHIT IS BORKE


Reproducible: Always


User Profile Reset: No



Additional Info:
LET ME SUBMIT THE FUCKING BUG REPORT YOU ASSHOLE HTML nerd with a hate so deep for everyone like me who is cooler than you! Who in their goddamned minds let you create this entire thing? I have a BFA in communication design, and I'd much rather redesign this for in exchange for moneys than know this exists outside of 1998. We can't even party like it's 1999, because this is older than that and is actually kind of gross when you look at the entire everything involved with ALL OF THIS BUG REPORT writing. Seriously? You don't have a team better than this? Yes, I insulted you and you have my email, and yes this is not as serious as you might feel but take the feedback. Update all of this immediatley (see this red underline under the typo in my word, you can totally see it correctly by right clicking it, but not when I copy it into my Libre Office document)!

I am sticking by my comment that this entire process has been "Gross"
Comment 1 anugo 2019-02-06 01:21:14 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0b21f6556b6fff76290d1095089da89532365215
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-05_02:51:41
Locale: en-US (en_US); UI-Language: en-US

Please refer to the attachment (spell_check_issue.jpeg) that been taken from stable build (Version: 6.1.4.2) where it is working as expected and from (Version: 6.3.0.0.alpha0+) where its not working as expected.
Comment 2 anugo 2019-02-06 01:22:50 UTC
Created attachment 148937 [details]
spell check broken issue in version:6.3.0.0.alpha0+
Comment 3 Timur 2019-02-07 15:09:34 UTC
Created attachment 148981 [details]
specll check works - screenshot from LO 6.3+.jpg

For me, spell check works in 6.3+. 
Please check option "Check spelling as you type".
Comment 4 Regis Perdreau 2019-02-08 04:27:39 UTC
May be some difficulties to have the wanted contextual menu.

With Version: 6.3.0.0.alpha0+, 

i have to put the cursor in the middle of the word, double click to have the word selected and right click to have the word spelling contextual menu.

If i select the word with the mouse cursor and left click down, next when i press right click, i have the ordinary contextual menu (with paste option)

May be a misunderstood how it exactly works ?
Comment 5 Timur 2019-02-08 08:39:36 UTC
Please attach a document where spell check doesn't work. 
Better to also insert there a cropped screenshot/an image of right-click menu.
Comment 6 QA Administrators 2019-08-19 07:02:47 UTC
Dear James,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INSUFFICIENTDATA
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-NeedInfo-Ping