Bug 123204 - EDITING Not all special characters appear in the AutoFilter window ( Hungarian )
Summary: EDITING Not all special characters appear in the AutoFilter window ( Hungarian )
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2019-02-06 09:58 UTC by NISZ LibreOffice Team
Modified: 2019-03-29 17:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem in Calc. (70.95 KB, image/png)
2019-02-06 10:02 UTC, NISZ LibreOffice Team
Details
Example file from Calc. (7.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-06 10:02 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-06 09:58:07 UTC
Description:
Not all special characters appear in the AutoFilter window.

Steps to Reproduce:
    1. Create a new spreadsheet in LibreOffice Calc.
    2. Select the A1 cell and type text.
    3. Enter some special characters to cells in A column. (e.g.: ? - % / [ ] ; “ { } @)
    4. Select the A1 cell and click Data→AutoFilter.
    5. Click on the AutoFilter popup menu button in A1 cell.

Actual Results:
Not all special characters appear in the AutoFilter window.

Expected Results:
All special characters should appear in the AutoFilter window.


Reproducible: Always


User Profile Reset: No



Additional Info:
Bibisected with: bibisect-win32-6.1


68f7b969267b44d037ae8e9e9550d09512e35374 is the first bad commit
commit 68f7b969267b44d037ae8e9e9550d09512e35374
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Mar 30 21:50:38 2018 -0700

    source sha:7b1eb6313c0d2621c364df1724c69d28f8267841

    source sha:7b1eb6313c0d2621c364df1724c69d28f8267841

:040000 040000 fee7b2b2589f90ad3a3abcf32a606c3ec6f11cce 5eddcfe1670a12c3da8878e4a8a7f1cfbd0b8123 M      instdir


commit 7b1eb6313c0d2621c364df1724c69d28f8267841
author László Németh <nemeth@numbertext.org> Tue Mar 27 22:42:18 2018 +0200 
committer László Németh <nemeth@numbertext.org> Thu Mar 29 16:45:33 2018 +0200 
tree f6a63022a8c80874e0210023465f82b1f7df729a 
parent 36c4fe664c90cebe3456bcb2cc3c463f94bf4dd0



Bibisect log:
$ git bisect log
# bad: [84f4d9d1c1b9d0a1c0f0307dafefb33cfbd78c65] source sha:d6f563b37d8a694c6c1d4c9ef3ba746c7f019517
# good: [29d08f54c2f71ffee4fe12dbb24c5f5cbedecfd2] source sha:6eeac3539ea4cac32d126c5e24141f262eb5a4d9
git bisect start 'origin/master' 'oldest'
# good: [47119681132d8fba09bb30e916fb0337372a93ca] source sha:ca638eedc65a7f9ae99094a728696905ca95766d
git bisect good 47119681132d8fba09bb30e916fb0337372a93ca
# bad: [c230edcfa7c597ba66c6a8731de7eaff31f4ff7a] source sha:962fdca5f1921722c18af8409bc17e9d9cd68d03
git bisect bad c230edcfa7c597ba66c6a8731de7eaff31f4ff7a
# good: [70b6fb3239bd48dc398edf7510fdf8cf817843fe] source sha:4475ccdc3d8f7089ad44f4b01c2d589a607e8e48
git bisect good 70b6fb3239bd48dc398edf7510fdf8cf817843fe
# bad: [f3ee5aa225741814a8b53ba1a1bf6f3341947f67] source sha:b524de950c6eb0bc61d05d41fe69b67ab59b16c6
git bisect bad f3ee5aa225741814a8b53ba1a1bf6f3341947f67
# bad: [6b34836808971935268a963c045989b0fca825ed] source sha:c110c93a283816a69be917d534b8ba321adf2133
git bisect bad 6b34836808971935268a963c045989b0fca825ed
# bad: [5aae46d33cd8a7854b55a1d8a6d4654293bfbb1a] source sha:6e7f6dd20aa58cb4c9ab66260a62d71a53002b9b
git bisect bad 5aae46d33cd8a7854b55a1d8a6d4654293bfbb1a
# bad: [3439d695a3ffadc5626e7c492c7afd9761a5ebea] source sha:f04f48e1517509930ba34bf7bd5b412508b7b7a2
git bisect bad 3439d695a3ffadc5626e7c492c7afd9761a5ebea
# good: [919ba6e0a41fba914396cd394907845c06beda29] source sha:c6bc9f71fb3bf92291bb7253f402d8d283ca8679
git bisect good 919ba6e0a41fba914396cd394907845c06beda29
# good: [74067fb4f5b23a02e27376f56bb463e111231c73] source sha:f62fcab7f16a2c6abbc37a0d83145e9ded3ad6e3
git bisect good 74067fb4f5b23a02e27376f56bb463e111231c73
# bad: [68f7b969267b44d037ae8e9e9550d09512e35374] source sha:7b1eb6313c0d2621c364df1724c69d28f8267841
git bisect bad 68f7b969267b44d037ae8e9e9550d09512e35374
# good: [4bf2c1af86abc9faff3d5762408884ff467f771f] source sha:73e6a7975b3508c5cfccb3df7c35b0303f87d9bb
git bisect good 4bf2c1af86abc9faff3d5762408884ff467f771f
# good: [525856520bbb7222404920b80676da6763c9448b] source sha:bcf0b17badb760ef852c39cbe192ce4f78ad55fc
git bisect good 525856520bbb7222404920b80676da6763c9448b
# good: [c26b3337e098622eab4bef4ea60bcf67704e0fce] source sha:36c4fe664c90cebe3456bcb2cc3c463f94bf4dd0
git bisect good c26b3337e098622eab4bef4ea60bcf67704e0fce
# first bad commit: [68f7b969267b44d037ae8e9e9550d09512e35374] source sha:7b1eb6313c0d2621c364df1724c69d28f8267841
Comment 1 NISZ LibreOffice Team 2019-02-06 10:02:21 UTC
Created attachment 148945 [details]
Screenshot of the problem in Calc.
Comment 2 NISZ LibreOffice Team 2019-02-06 10:02:50 UTC
Created attachment 148946 [details]
Example file from Calc.
Comment 3 Durgapriyanka 2019-02-06 17:44:21 UTC
Thank you for reporting the bug. I cannot reproduce the bug. All special characters do appear in the Autofilter window.

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-02-07 17:31:40 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 6287a4f0d18df7f195d1f14b7c24536317463a23
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 5 Gabor Kelemen 2019-02-07 19:03:46 UTC
I don't reproduce with: 

Version: 6.3.0.0.alpha0+
Build ID: a7521570c95cf4ecd3eb4324581ad09ff30ff70a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (hu_HU.UTF-8); UI-Language: en-US
Calc: threaded

But I do with: 

Version: 6.3.0.0.alpha0+
Build ID: a7521570c95cf4ecd3eb4324581ad09ff30ff70a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: hu-HU (hu_HU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2019-02-11 16:09:28 UTC
Hi Gabor,
I see different locales in your builds. locale dependent ?
Comment 7 Gabor Kelemen 2019-02-11 19:19:21 UTC
(In reply to Xisco Faulí from comment #6)
> Hi Gabor,
> I see different locales in your builds. locale dependent ?

Seems like yes. 
Bibisected commit touched Hungarian collation rules so that's quite suspicious:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7b1eb6313c0d2621c364df1724c69d28f8267841
Comment 8 Xisco Faulí 2019-02-12 16:17:11 UTC
Moving to NEW at it has been bisected...
Comment 9 Xisco Faulí 2019-02-12 16:35:44 UTC
Adding Cc: to László Németh
Comment 10 Commit Notification 2019-03-21 08:46:12 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7618490d334409c3fc4167f32732537ef738647f%5E%21

tdf#123204 hu_HU collation: don't ignore special characters

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-03-29 17:11:23 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/37f5c96da886f82b819e375feab0a871cab28513%5E%21

tdf#123204 hu_HU collation: don't ignore special characters

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.