Bug 123225 - Loss of functions in XLSX pivot table's context menu until refreshed (see comment 18)
Summary: Loss of functions in XLSX pivot table's context menu until refreshed (see com...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2019-02-07 11:23 UTC by Pradip_0382
Modified: 2019-03-08 00:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
atached the xlxs file created in lunix machine (25.64 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-07 11:29 UTC, Pradip_0382
Details
test pivot - ods (26.77 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-12 21:56 UTC, raal
Details
atached the xlxs file created in lunix machine (987.79 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-22 14:17 UTC, Pradip_0382
Details
ODS with pivot table created in Calc (299.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-22 15:10 UTC, Pradip_0382
Details
Screenshot of Excel's context menu (29.22 KB, image/png)
2019-03-08 00:24 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pradip_0382 2019-02-07 11:23:46 UTC
Description:
I am creating a pivot table with LibreOffice calc 6.1 in linux and try to save as to 'Excel 2007-2019(.xlsx)' to create an .xlsx file to open in window machine with MS office 2016/2010.

When i open the same .xlsx file window machine then i can see only the text data in pivot sheet.all pivot functionality has been lost but same file working good in linux machine where it created.



Steps to Reproduce:
1.Create pivot table with libreoffice calc in linux machine
2. Saveas to .xlsx file with filter 'Excel 2007-2019' 
3. working good
4. Transfer the same .xlsx file to windows machine 
5. open the same .xlsx file in windows machine with ms office 2016


Actual Results:
I can see only the text data in pivot sheet and all pivot functionality moved out.

Expected Results:
all pivot functionality moved should be there in windows machine


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Pradip_0382 2019-02-07 11:29:51 UTC
Created attachment 148977 [details]
atached the xlxs file created in lunix machine
Comment 2 Roman Kuznetsov 2019-02-07 11:45:58 UTC
please attach source ODS file
Comment 3 Roman Kuznetsov 2019-02-07 11:49:10 UTC
(In reply to Roman Kuznetsov from comment #2)
> please attach source ODS file

I'm sorry. You direct save file to XLSX from LibreOffice without creating of ODS file, right?
Comment 4 Pradip_0382 2019-02-11 13:22:06 UTC
yes we can save the file directly xlsx in linux machine with LibreOffice but my problem is that the pivot functionality is not working in windows machine with MS office.
Comment 5 Pradip_0382 2019-02-11 13:31:12 UTC
Can you confirm if the xlsx file created with pivot table in Linux machine can be opened in MS office (Windows Machine) without any lost of pivot functionality. Please let me know the process.
Comment 6 Xisco Faulí 2019-02-12 16:38:50 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 7 raal 2019-02-12 21:56:24 UTC
Created attachment 149242 [details]
test pivot - ods

Tested with Version: 6.3.0.0.alpha0+
Build ID: c7ad7849d54fd3dad67e7779102f65b8b2f04881
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

after save as xlsx I can open pivot in excel2010. We need your .ods file to reproduce the bug.
Comment 8 raal 2019-02-12 21:58:22 UTC
Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
Comment 9 Aron Budea 2019-02-12 23:50:05 UTC
I opened a similar bug report, bug 123421 on various pivot table export issues, and noted that the file exported from LO 6.1.0.3 wasn't even a proper pivot table, and your version is close to that.

Pradip, please give it a try with a 6.3 daily build from here: https://dev-builds.libreoffice.org/daily/master/
Comment 10 Pradip_0382 2019-02-22 06:16:50 UTC
Hi,
I tried with 6.3 libreoffice.
Created pivot report and save as .xlsx in Linux machine.Tried to open the same file in windows machine with Ms office. 

Issue:Missing some functionalities  of pivot report. but after click refresh button i can get all pivot functionalities there.

Is there any fix for to overcome the refresh button click?
Comment 11 Aron Budea 2019-02-22 06:53:08 UTC
Please attach a sample ODS created in LibreOffice, an already buggy file is not useful in itself.
Comment 12 Pradip_0382 2019-02-22 14:17:35 UTC
Created attachment 149530 [details]
atached the xlxs file created in lunix machine

Attached the xlsx file created in linux machine with libreoffice 6.3
Comment 13 Aron Budea 2019-02-22 14:29:53 UTC
Again, please attach the spreadsheet in ODS format, so the correctness of export can be tested both now and after a future fix.
Comment 14 Pradip_0382 2019-02-22 15:10:25 UTC
Created attachment 149532 [details]
ODS with pivot table created in Calc

Attached the requested ods file also created from linux system
Comment 15 Pradip_0382 2019-02-25 11:54:33 UTC
Hi Team,

Any update on my request please?

Regards,
Pradip
Comment 16 Pradip_0382 2019-02-26 15:49:11 UTC
Dear Baron,

Can I have any update please.

Regards,
Pradip
Comment 17 raal 2019-02-27 15:26:10 UTC
correcting status
Comment 18 Aron Budea 2019-03-08 00:23:46 UTC
Thanks for the sample, Pradip! I can confirm the loss of functions in Excel until the pivot table is refreshed.
Another very simple sample for repro (an XLSX created in Excel): attachment 133861 [details].

- Roundtrip the sample in Calc, and open in Excel.
- Right click on a cell inside the table.

=> The menu has a lot fewer options than the original until the pivot table is refreshed.

Observed using LO 6.3.0.0.alpha0+ (4f810905fa74128871f2fe924a3d28a79f4e4261) / Windows 7.
Comment 19 Aron Budea 2019-03-08 00:24:39 UTC
Created attachment 149810 [details]
Screenshot of Excel's context menu