Download it now!
Bug 123307 - Tabbed Interface - No It's Not
Summary: Tabbed Interface - No It's Not
Status: RESOLVED DUPLICATE of bug 37134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-10 16:18 UTC by sumbuddy99
Modified: 2019-02-14 13:15 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sumbuddy99 2019-02-10 16:18:47 UTC
Description:
The latest version of LO says it introduces a "tabbed interface." Perhaps you don't know what a tabbed interface is. Look at any web browser. What you have introduced is that god-awful ribbon interface. Years ago, IBM produced a product named Lotus Symphony, which was basically a better interface on top of OpenOffice code. It had a real "tabbed interface." It opened 1 single window, with every document on a separate tab in that window. When IBM/Lotus discontinued that product, they released the code to the OpenOffice community. Yet years later, neither OO nor LO seem able to produce a product that is capable of having 1 window with every document on a separate tab in that window, something web browsers have been doing practically forever. LO, OO, and even MS Office still need a separate window for every document. This gets pretty messy when you have 10 documents open. I have 2 requests/suggestions:

1. Stop calling your new interface by the false name "tabbed interface."

2. Produce a product with a real "tabbed interface." IBM/Lotus has given you the code. It shouldn't be much more difficult than a copy/paste operation.

Steps to Reproduce:
1. Open 10 documents.
2. Count how many separate windows are open.
3. Open 10 web pages in any browser.
4. Count how many separate windows are open.

Actual Results:
Step 2 = 10 separate windows are open.
Step 4 = 1 window is open with 10 tabs.

Expected Results:
LO should include capabilities that have been available for decades, the code for which was donated to them by IBM/Lotus.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no

Yes, my OS is 64 bit. Don't know why you say it isn't.
Comment 1 Adolfo Jayme 2019-02-12 12:58:35 UTC
Whay you’re asking for is called MDI, short for “multiple-document interface”, and there is already an enhancement request open for implementing that.


> IBM/Lotus has given you the code

FYI… No, it hasn’t. Ever wondered why hasn’t AOO added MDI either? Now you know.
Comment 2 Timur 2019-02-14 13:15:48 UTC
Not Invalid but duplicate.

*** This bug has been marked as a duplicate of bug 37134 ***