Bug 123356 - FILEOPEN DOCX COUNT table formula is not working in LO
Summary: FILEOPEN DOCX COUNT table formula is not working in LO
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: DOCX-Fields Regressions-expression-is-faulty
  Show dependency treegraph
 
Reported: 2019-02-11 15:31 UTC by NISZ LibreOffice Team
Modified: 2020-08-31 11:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer. (291.04 KB, image/png)
2019-02-11 15:32 UTC, NISZ LibreOffice Team
Details
Document with COUNT table formulas. (20.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-11 15:32 UTC, NISZ LibreOffice Team
Details
Simplier Count formula (19.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-12 11:08 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-11 15:31:34 UTC
Description:
COUNT table formula has Expression is faulty when opened in LO.

Steps to Reproduce:
    1. Create a new docx in Word.
    2. Insert a Table.
    3. Insert COUNT() formula to some of the cells.
    4. Save and open it in LO.

Actual Results:
The cells which had and COUNT formula now have ** Expression is faulty ** instead of what was in them in Word.

Expected Results:
All the cells should have the same data in them.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details: Version: 6.3.0.0.alpha0+
Build ID: 17dd2662ccfa9d04efbea74e5d7548db5b2126d4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 NISZ LibreOffice Team 2019-02-11 15:32:18 UTC
Created attachment 149153 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2019-02-11 15:32:40 UTC
Created attachment 149154 [details]
Document with COUNT table formulas.
Comment 3 Xisco Faulí 2019-02-12 00:02:30 UTC
The problem is it's using

debug:29011:29011: COUNT(LEFT)
debug:29011:29011: COUNT(RIGHT)
debug:29011:29011: COUNT(ABOVE)

can be closed as a dupe of bug 123355

*** This bug has been marked as a duplicate of bug 123355 ***
Comment 4 Xisco Faulí 2019-02-12 11:07:51 UTC
The attached document contains below/above/right/left which can't be handle by
Writer atm. Attaching a new Formula with COUNT without those...
Comment 5 Xisco Faulí 2019-02-12 11:08:20 UTC
Created attachment 149219 [details]
Simplier Count formula
Comment 6 Commit Notification 2020-08-23 11:07:45 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f1f27b2487ccfb7a03190ff68eadbfb611dd9749

tdf#123356 DOCX import: fix COUNT formula

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-08-27 07:17:58 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/894a0f77c12f3ac4029bdeb671943f32bcad875c

Revert "tdf#123356 DOCX import: fix COUNT formula"

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-08-27 07:18:09 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/79681f6a35ebf70293136034d675d312c5b6cdee

tdf#123356 sw: add table formula COUNT

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-08-31 11:51:20 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!