Bug 123359 - FILEOPEN DOCX IF table formula is not working in LO
Summary: FILEOPEN DOCX IF table formula is not working in LO
Status: RESOLVED DUPLICATE of bug 123377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Fields Regressions-expression-is-faulty
  Show dependency treegraph
 
Reported: 2019-02-11 15:39 UTC by NISZ LibreOffice Team
Modified: 2019-02-12 10:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer. (284.94 KB, image/png)
2019-02-11 15:39 UTC, NISZ LibreOffice Team
Details
Document with IF table formulas. (20.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-11 15:40 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (282.37 KB, image/png)
2019-02-11 15:50 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-11 15:39:21 UTC
Description:
IF table formula has Expression is faulty when opened in LO.

Steps to Reproduce:
    1. Create a new docx in Word.
    2. Insert a Table.
    3. Insert IF() formula to some of the cells.
    4. Save and open it in LO.

Actual Results:
The cells which had and IF formula now have ** Expression is faulty ** instead of what was in them in Word.

Expected Results:
All the cells should have the same data in them.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details: Version: 6.3.0.0.alpha0+
Build ID: 17dd2662ccfa9d04efbea74e5d7548db5b2126d4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 NISZ LibreOffice Team 2019-02-11 15:39:47 UTC
Created attachment 149157 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2019-02-11 15:40:22 UTC
Created attachment 149158 [details]
Document with IF table formulas.
Comment 3 NISZ LibreOffice Team 2019-02-11 15:50:13 UTC
Created attachment 149161 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 4 Xisco Faulí 2019-02-11 19:17:38 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c568eb7d3bb4584867f0a1f0a7965f73097f009b

author	Jean-Sebastien Bevilacqua <realitix@gmail.com>	2017-02-16 09:54:33 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-30 17:39:00 (GMT)
commit	c568eb7d3bb4584867f0a1f0a7965f73097f009b (patch)
tree	ea7e6fb1e0d77369a90bc69dd8756f589bb352e4
parent	53c2507bf97867011fd2bfbbac6c86b7fc494338 (diff)
tdf#105975 Add Formula field parsing (docx) in SWriter
Introduction

Bisected with bibisect-linux-64-5.4

Adding Cc: to Jean-Sebastien Bevilacqua
Comment 5 Xisco Faulí 2019-02-12 00:51:07 UTC
Actually, the problem is that writer doesn't handle If expressions correctly. Which is an older regression I've just reported in bug 123377.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 123377 ***