Bug 123363 - Image randomly lost permanently
Summary: Image randomly lost permanently
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Undo-Redo Image-Compression
  Show dependency treegraph
 
Reported: 2019-02-11 16:10 UTC by Telesto
Modified: 2022-08-18 03:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (2.41 MB, video/mp4)
2019-02-11 16:11 UTC, Telesto
Details
Resulting file when saving (866.12 KB, application/vnd.oasis.opendocument.graphics)
2019-02-11 16:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-02-11 16:10:08 UTC
Description:
Image randomly lost permanently. Behaves like out of memory issue (OOM)

Steps to Reproduce:
1. Open attachment 149162 [details]
2. Compress PNG to JPG 600
3. Compress the JPG to JPG 600
4. Undo -> Retry step 2/3

No warrantees.. Did happen 3 times in a row couldn't repro it

Actual Results:
The image will be lost sometimes

Expected Results:
Not losing images


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 0b21f6556b6fff76290d1095089da89532365215
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2019-02-11 16:11:21 UTC
Created attachment 149163 [details]
Screencast
Comment 2 Telesto 2019-02-11 16:12:03 UTC
Created attachment 149164 [details]
Resulting file when saving
Comment 3 Durgapriyanka 2019-02-13 17:51:31 UTC
I can confirm the bug present in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Buovjaga 2019-02-17 15:41:59 UTC
Tried several times, but no problem.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: e0745a11597e5d57eb8001a295314e86810a6027
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-12_02:44:15
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 5 Telesto 2019-02-17 17:13:03 UTC
(In reply to Buovjaga from comment #4)
> Tried several times, but no problem.

Sadly, that's part of the problem... I also have hard time reproducing it.. but seen all the bug floating around with 'missing images, again'.... so everybody has hard time proving the problem..

Anyway.. there a some criteria to improve the reproducibility
- x32 build -> it behaves like out of memory bug (except the regular crashing part). 
- Debug build -> I reproduced it the first time with a debug build.

So or something OOM related or timing problem cleanup of memory before 'securing' the image...

Will try a new debug build...
Comment 6 QA Administrators 2022-08-18 03:40:39 UTC
Dear Telesto,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug