Bug 123380 - LibreOfficeKit: Does not load and convert the attached document
Summary: LibreOfficeKit: Does not load and convert the attached document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-12 07:33 UTC by Murat
Modified: 2019-04-05 07:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
.doc file with some vb macros (9.04 MB, application/msword)
2019-02-12 07:33 UTC, Murat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Murat 2019-02-12 07:33:03 UTC
Created attachment 149178 [details]
.doc file with some vb macros

Hi,
My system is Centos 6, I tried versions libreoffice-6.0.7.3, libreoffice-6.1.3.2, libreoffice5.4, libreoffice6.2

The attached document cannot be loaded and waits forever in:

"Document * lodoc = llo->documentLoad(input_url.c_str(),options);"

It never returns from this function. It hangs forever, no error at all(After about 2 hours converted the document).

I tried the same document with both Libreoffice writer GUI and unoconv. They both worked without any problem.

Thanks so much,
Comment 1 Regis Perdreau 2019-04-04 00:30:07 UTC
Confirmed with load by hand in Libreoffice.
Import of a .doc file is a lot slower than in 6.0.7.3 version.
No macros imported.


Version: 6.3.0.0.alpha0+
Build ID: 413461e3cf3a4b32a17419f67f879a8975c43987
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded


the import progress bar seems to go slower and slower and will reach the end after  5 minutes around althought the UI stays responsive, you can open another file.


Unconfirmed with version Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: x11; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
load in less then 20 secondes...

no macro in macro editor.
Comment 2 Regis Perdreau 2019-04-04 00:43:18 UTC
Set to new because of the lack of import speed .
Comment 3 Murat 2019-04-05 07:32:20 UTC
By the way I did not have any problem while opening from GUI with versions libreoffice-6.0.7.3, libreoffice-6.1.3.2, libreoffice5.4, libreoffice6.2, 

I have the problem here in libreofficekit:

LibreOfficeKit.hxx ==>>

    /**
     * Loads a document from an URL.
     *
     * @param pUrl the URL of the document to load
     * @param pFilterOptions options for the import filter, e.g. SkipImages.
     *        Another useful FilterOption is "Language=...".  It is consumed
     *        by the documentLoad() itself, and when provided, LibreOfficeKit
     *        switches the language accordingly first.
     * @since pFilterOptions argument added in LibreOffice 5.0
     */
    Document* documentLoad(const char* pUrl, const char* pFilterOptions = NULL)
    {
        LibreOfficeKitDocument* pDoc = NULL;

        if (LIBREOFFICEKIT_HAS(mpThis, documentLoadWithOptions))
            pDoc = mpThis->pClass->documentLoadWithOptions(mpThis, pUrl, pFilterOptions);
        else
            pDoc = mpThis->pClass->documentLoad(mpThis, pUrl);

        if (pDoc == NULL)
            return NULL;

        return new Document(pDoc);
    }