Bug 123383 - FILEOPEN DOCX Table formulas with position specifiers are missing when opened
Summary: FILEOPEN DOCX Table formulas with position specifiers are missing when opened
Status: RESOLVED DUPLICATE of bug 122648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Fields Regressions-expression-is-faulty
  Show dependency treegraph
 
Reported: 2019-02-12 07:45 UTC by NISZ LibreOffice Team
Modified: 2020-09-25 13:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the document side by side in Writer and Word. (82.94 KB, image/png)
2019-02-12 07:46 UTC, NISZ LibreOffice Team
Details
Original document with table formulas. (18.25 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-12 07:46 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-12 07:45:44 UTC
Description:
Table formulas using LEFT, RIGHT, ABOVE, BELOW position specifiers display wrong values or go missing regardless of the type of formula.

Steps to Reproduce:
    1. Create a new docx in Word.
    2. Insert a table.
    3. Insert some formulas inside the table with LEFT, RIGHT, ABOVE, BELOW position specifiers
    4. Save and open it in LO.

Actual Results:
The formulas display either 0 value instead of a nonzero, or “expression faulty” error.

Expected Results:
They should still be there.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 950bdd703bb4430526598a132897a6b77cb21005
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 NISZ LibreOffice Team 2019-02-12 07:46:10 UTC
Created attachment 149183 [details]
Screenshot of the document side by side in Writer and Word.
Comment 2 NISZ LibreOffice Team 2019-02-12 07:46:30 UTC
Created attachment 149184 [details]
Original document with table formulas.
Comment 3 Xisco Faulí 2019-02-12 10:27:30 UTC
Formulas:

debug:7354:7354: =SUM(ABOVE;LEFT)
debug:7354:7354: =SUM(RIGHT;ABOVE)
debug:7354:7354: =SUM(BELOW;LEFT)
debug:7354:7354: =SUM(RIGHT;BELOW)
debug:7354:7354: =SUM(LEFT)
debug:7354:7354: =SUM(LEFT;RIGHT)
debug:7354:7354: =SUM(RIGHT)
debug:7354:7354: =SUM(ABOVE)
debug:7354:7354: =SUM(ABOVE;BELOW)
debug:7354:7354: =SUM(BELOW)


Closing as a dupe of bug 123355

*** This bug has been marked as a duplicate of bug 123355 ***
Comment 4 Timur 2020-09-15 08:51:41 UTC Comment hidden (me-too)
Comment 5 Timur 2020-09-15 09:00:01 UTC
This attachment 149184 [details] not resolved. 
attachment 149199 [details] from bug 123391 and attachment 149201 [details] from bug 123392 with SUM are OK.
Comment 6 Timur 2020-09-25 13:13:02 UTC
More changes, final fix with source sha:782700c6940341d489eabf00a531cb184941484e of bug 122648.

*** This bug has been marked as a duplicate of bug 122648 ***