Bug 123385 - FILEOPEN DOCX NOT table formula is not working in LO
Summary: FILEOPEN DOCX NOT table formula is not working in LO
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOCX-Fields Regressions-expression-is-faulty
  Show dependency treegraph
 
Reported: 2019-02-12 07:51 UTC by NISZ LibreOffice Team
Modified: 2020-09-01 14:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document side by side in Word and Writer. (276.97 KB, image/png)
2019-02-12 07:52 UTC, NISZ LibreOffice Team
Details
Document with NOT table formulas. (20.23 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-12 07:52 UTC, NISZ LibreOffice Team
Details
Screenshot of the document in yesterdays nightly (23.15 KB, image/png)
2020-08-25 06:49 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-12 07:51:35 UTC
Description:
NOT table formula has Expression is faulty when opened in LO.

Steps to Reproduce:
    1. Create a new docx in Word.
    2. Insert a Table.
    3. Insert NOT() formula to some of the cells.
    4. Save and open it in LO.

Actual Results:
The cells which had and NOT formula now have ** Expression is faulty ** instead of what was in them in Word.

Expected Results:
All the cells should have the same data in them.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details: Version: 6.3.0.0.alpha0+
Build ID: 17dd2662ccfa9d04efbea74e5d7548db5b2126d4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 1 NISZ LibreOffice Team 2019-02-12 07:52:00 UTC
Created attachment 149187 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2019-02-12 07:52:16 UTC
Created attachment 149188 [details]
Document with NOT table formulas.
Comment 3 Xisco Faulí 2019-02-12 10:46:52 UTC
Formula

debug:8228:8228: =NOT(2=3)
Comment 4 NISZ LibreOffice Team 2020-08-25 06:49:39 UTC
Created attachment 164656 [details]
Screenshot of the document in yesterdays nightly

Seems to work fine after:

https://git.libreoffice.org/core/+/68e74bdf63e992666016c790e8e4cfd5b28d6abe%5E%21

author	Michael Warner <michael.warner.ut+libreoffice@gmail.com>	Fri Jul 03 10:18:33 2020 -0400
committer	László Németh <nemeth@numbertext.org>	Mon Aug 17 11:15:25 2020 +0200

tdf133647 tdf123386 tdf123389 Improved .docx table formula import

Version: 7.1.0.0.alpha0+ (x86)
Build ID: a06a83b29a9da770787bffe416b138102aa12531
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2020-08-25 06:53:44 UTC
Also survives saving.

Thanks Michael and László!
Comment 6 BogdanB 2020-08-31 21:44:32 UTC
Verified in
Version: 7.1.0.0.alpha0+
Build ID: e2f4e65a7b8024c00b049eebf0d87637efda7f24
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 7 Xisco Faulí 2020-09-01 14:36:21 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 828914a94fe93d5b300bda1d23a049ae92c159e1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

No need for a unittest since https://git.libreoffice.org/core/+/68e74bdf63e992666016c790e8e4cfd5b28d6abe%5E%21 already covers things like NOT(TRUE) or ((<A1> EQ 1) OR (<B1> EQ 2)) or ((<A1> EQ 1) AND (<B1> EQ 2))