Bug 123452 - Big file size due to missing compression of EMF files
Summary: Big file size due to missing compression of EMF files
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:6.3.0 target:6.2.2 target:6.1.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-02-13 21:51 UTC by AnFr
Modified: 2019-03-13 14:52 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test files archive (1.11 MB, application/x-zip-compressed)
2019-02-13 21:57 UTC, AnFr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AnFr 2019-02-13 21:51:41 UTC
Description:
Testing the LibreOffice 6.1.5 for company usage I've seen that formally compact files are getting big, if saved with LibreOffice 6.x.
Specially Files with EMF pictures.
Making a copy of the files to [formername].zip and enter them with an archive browser I've found that the new Libre Office does not compress the EMF files.
With the actually used version 5.3.7 the EMF files in the directory 'Pictures' have a high compression rate.

Steps to Reproduce:
1. Generate an ODT file and import one ore more graphics.
2. Open the file with an older version (e.g. 5.3.7) and SaveAs.
3. Open the file with an actual version (e.g. 6.1.5) and SaveAs.
--> compare the file sizes

Actual Results:
The file saved with 6.1.5 has the size of the uncompressed graphics.
The file saved with 5.3.7 is much smaller.

Expected Results:
the file sizes should be similar.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Tested with

Setup 1:
Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

Setup 2:
Version: 5.3.7.2
Build-ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU-Threads: 4; BS-Version: Windows 6.1; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group

Setup 3:
Version: 6.0.6.2
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

Setup 4:
Version: 6.0.7.3
Build-ID: 1:6.0.7-0ubuntu0.18.04.2
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 1 AnFr 2019-02-13 21:57:09 UTC
Created attachment 149286 [details]
test files archive

In the attached archive 6 files are included:
3 ODT files saved with different LibreOffice versions.
3 PNG files showing the compression rate of the different LibreOffice versions.
Comment 2 Telesto 2019-02-14 08:32:02 UTC
Repro
Version: 6.3.0.0.alpha0+
Build ID: e0745a11597e5d57eb8001a295314e86810a6027
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-02-12_04:16:22
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 AnFr 2019-02-25 12:15:01 UTC
Hi Experts.
Is there a Expert Configuration Key to activate/deactivate this behavior?

Best Regards,
Anfr
Comment 4 AnFr 2019-02-25 12:18:51 UTC
Due to the behavior, that files become non E-Mail conform sizes, I think the importance level should be higher than normal.

Best Regards,
AnFr
Comment 5 Telesto 2019-02-25 16:00:19 UTC
(In reply to AnFr from comment #4)
> Due to the behavior, that files become non E-Mail conform sizes, I think the
> importance level should be higher than normal.
Comment 6 Buovjaga 2019-02-25 18:11:11 UTC
(In reply to AnFr from comment #4)
> Due to the behavior, that files become non E-Mail conform sizes, I think the
> importance level should be higher than normal.

I don't think so: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Higher severities are mostly for crashes and such.
Comment 7 Buovjaga 2019-03-03 15:06:54 UTC
Bibisected with win32-6.2 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/4cb1e86e5217f09e1d98e51e46803a06fb72f5ce%5E!/
tdf#103913 keep ".emf" file extension and mime type

Adding Cc: to László Németh. Seems like this is a feature rather than a bug?
Comment 8 Bartosz 2019-03-04 21:19:49 UTC
The issue could be easily resolved. I will prepare patch with the fix soon.
Comment 9 Bartosz 2019-03-04 22:54:22 UTC
Review is available at:
https://gerrit.libreoffice.org/#/c/68716/
Comment 10 Commit Notification 2019-03-05 06:44:30 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/df22e97db5b7608b6d53b15b86b5a83610f9c87b%5E%21

tdf#123452 EMF Re-enable compression for image/x-emf files

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-03-06 00:17:23 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/36f027769ea6aaabb5e993a321d7a56775d4bee1%5E%21

tdf#123452 EMF Re-enable compression for image/x-emf files

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 AnFr 2019-03-07 08:50:10 UTC
Hi,

the patch is working for me.
Tested with 'Master~20190306'.

Will be there a Commit to the 6.1.6 too?

Kind Regards,
AnFr
Comment 13 Bartosz 2019-03-07 12:46:56 UTC
I would like to push patch to LO 6.1 with review:
https://gerrit.libreoffice.org/#/c/68730/

Unfortunately there is some issue with Windows. I think it is infrastructure and it is not related to this patch.
Comment 14 Commit Notification 2019-03-07 20:26:16 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/0c0cdc8e3fa4566e8f2aee77a584b4ee43faaa2d%5E%21

tdf#123452 EMF Re-enable compression for image/x-emf files

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2019-03-13 14:51:47 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-2":

https://git.libreoffice.org/core/+/d08b00ccddc136f6fbeb6fe1be9b3c694b5ff242%5E%21

tdf#123452 EMF Re-enable compression for image/x-emf files

It will be available in 6.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.