Bug Hunting Session
Bug 123535 - Ctrl + "-" between symbols look not good
Summary: Ctrl + "-" between symbols look not good
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-02-18 07:04 UTC by seven
Modified: 2019-02-18 15:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample (31.58 KB, image/png)
2019-02-18 07:05 UTC, seven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description seven 2019-02-18 07:04:38 UTC
Description:
Showing Ctrl + "-" is not good

Steps to Reproduce:
1. Enter symbol 3
2. Enter symbol by press Ctrl + "-"
3. Enter symbol 4

Actual Results:
symbol - is touch near symbol

Expected Results:
symbol - is between 3 and 4 and do not touch


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 seven 2019-02-18 07:05:16 UTC
Created attachment 149361 [details]
Sample
Comment 2 Dieter Praas 2019-02-18 07:32:12 UTC
I confirm it with

Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded

Expected result for me: same rendering as if you only press "-"
Comment 3 Khaled Hosny 2019-02-18 15:51:27 UTC
Soft-hyphen (the one you get by pressing ctl + -) is a control character that tells the application it is allowed to hyphenate here. Control characters have zero width because they should not normally change the layout. If you export to PDF the hyphen will completely disappear. If you want regular hyphen, use - or ‐ (U+2010).