Bug 123641 - Emailmerge: can not connect to SMTP server with TLS
Summary: Emailmerge: can not connect to SMTP server with TLS
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2019-02-22 09:43 UTC by Ferry Toth
Modified: 2019-09-26 11:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
TLS on port 465 (134.68 KB, image/png)
2019-02-22 09:43 UTC, Ferry Toth
Details
STARTTLS on port 25 (82.62 KB, image/png)
2019-02-22 09:46 UTC, Ferry Toth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ferry Toth 2019-02-22 09:43:07 UTC
Created attachment 149503 [details]
TLS on port 465

This bug may seem a duplicate but is not.

It is easy to reproduce by testing the SMTP server in <Tools><Options><Writer><E-mail>

The connection type that fails:
TLS on port 465 - see screenshot

Connection succeeds with"
STARTTLS on port 25 - see screenhot
Comment 1 Ferry Toth 2019-02-22 09:46:20 UTC
Created attachment 149506 [details]
STARTTLS on port 25
Comment 2 Ferry Toth 2019-02-22 09:50:24 UTC
Note: the TLS connection uses Password Authentication, the STARTTLS connection uses No Authentication.

Hint: testing SMTP with this dialog works fine in LibO 5.4, which I keep installed on my PC for just this purpose.
Comment 3 Julien Nabet 2019-02-24 15:34:39 UTC
Justin: thought you might be interested in this one
Comment 4 Justin L 2019-02-25 04:10:48 UTC
Why do you think this not a duplicate of bug 63388 comment 39?
> A few related changes have resulted in this situation for LO 6.1
> -secure SMTP is now default with port 587 (StartTLS).
> -Port 465 uses smtp_ssl (regardless of the setting labeled SSL,
>  but which actually implements StartTLS in the case of SMTP).
>  SO, PORT 465 IS THE ONLY PORT THAT LIBREOFFICE CAN USE FOR SSL SMTP.
> Todo:
> 1) The term "SSL" is correct for POP3/IMAP settings in the authentication
> portion (right?), but for SMTP, "SSL" is different (and incompatible) with
> "StartTLS". Consider the three-way logic of comment 18.

Is there a reason you can't use port 587?

A patch commit message states:
> Port 465 was temporarily recommended, but OFFICIALLY has long since been
> abandoned. However, LOTS of documentation and ISPs still recommend it as
> the port to use. I confirmed that 465 DOES NOT support STARTTLS (in gmail)
> so it is specifically excluded.
Comment 5 Xisco Faulí 2019-03-28 19:03:46 UTC
Dear Ferry Toth,
Please, answer comment 4 from Justin L.
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the question has been answered
Comment 6 Ferry Toth 2019-03-28 21:32:30 UTC
Bug 63388 affects 3.5.7.2. In comment 2 I write "testing SMTP with this dialog works fine in LibO 5.4".

SMTP port I used is the port as detected by Thunderbird for the particular providers I tried. Gmail was not one of them.

Other then this reason, what a strange question? The server determines the port right, not the client.
Comment 7 Ferry Toth 2019-03-28 22:05:20 UTC
I tried just now smtp.telfort.nl on port 587. The test fails due to both connection and searching server. This is one I use all the time with thunderbird (STARTTLS). It requires no login, but is closed from outside there domain.

This same server fails in the same way with port 465.

Same results for mail.antagonist.nl on both 587 and 465.

Maybe you could try to reproduce with something other then just gmail?
Comment 8 Xisco Faulí 2019-09-26 11:19:27 UTC
Dear Ferry Toth,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.