Download it now!
Bug 123664 - Allow easier entering of foreign language variants (i.e. accents) of characters on Mac OS
Summary: Allow easier entering of foreign language variants (i.e. accents) of characte...
Status: RESOLVED DUPLICATE of bug 42437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-23 15:03 UTC by jdhartung
Modified: 2019-02-25 11:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdhartung 2019-02-23 15:03:36 UTC
Description:
It's a small thing, but one of the annoying reasons I am leaving Open Office. But unfortunately I don't find that the feature is in Libre Office either, so I am asking for it. Most of the Mac programs I use allow me to hold down a key which has foreign language variants (i.e. accents). This then displays all the available variants of the character by number. One can then select the desired variant (by number) and pressing this number then replaces the standard character (i.e. e with é) It's all really simple and fast. I need this because I use a standard US keyboard layout, but live in o foreign country and write a lot in Spanish. I think it would be a great feature to add to Libre Office. Perhaps the code is actually already available to be dropped in, as the feature is already widely available in other programs. I hope so as I am really liking Libre Office and intend to replace Open Office with it. Best Regards, John D. Hartung

Actual Results:
The feature is apparently not present

Expected Results:
The feature is apparently not present


Reproducible: Didn't try


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2019-02-25 09:14:17 UTC
@jdhartung : I would guess that this is both locale and keyboard type dependent.

For example, you state that you are using a US keyboard. I, on the otherhand, use a FR keyboard, where having to type Shift-NumberKey (numbers are upper case on a fairly substantial majority of non-EN (US/UK) keyboards) is absolutely of no speed or UX advantage whatsoever in the scenario you describe. Obviously, I already have French accented characters directly on the keyboard, so the issue is moot in such a situation, but definitely not if I were typing in another language with accents or other extended characters (e.g. Spanish, German or Slavic languages).


The cheapest solution would no doubt be for you to buy a Spanish keyboard, which would enable you to continue using LibreOffice.


The point is whilst I agree that it would be nice to have the Apple suggested character support you also mention, that particular problem is a duplicate of bug 42437.

As you can see from the age of that bug report (7.5 years ago), nothing and no one has been sufficiently interested or motivated enough to implement that macOS feature into LibreOffice.
Comment 2 Alex Thurgood 2019-02-25 09:14:33 UTC

*** This bug has been marked as a duplicate of bug 42437 ***
Comment 3 jdhartung 2019-02-25 10:20:16 UTC
Hi Alex,
     Perhaps no one has bothered to mention it since your earlier bug report, but it would be a useful feature to me nonetheless. And I think it would also be useful to a number of us worldwide who must regularly type alternating in two or more languages. Yes, I could buy a Spanish keyboard, though it would be irritating to have to carry it around with my MacBook Pro. The Shift-Number Key feature is available on almost every other program that I use, including note taking, CAD, etc. etc. so I surmise that it really can't be that hard to implement.

    I can use Libre Office regardless, but in order to insert the properly accented foreign character I must open the character viewer, find and highlight the properly accented character (I have them all, upper and lower case, saved as favorites to save time) and double click it to insert. This is an arduous process as opposed to the Shift-Number Key method, which I find to be quite usable. FWIW, it also functions similarly on my iPhone, i.e. the ! key held down brings up a dialog that allows one to select ¡

    I hope you'll consider adding this Apple suggested feature.

Best Regards, J.
Comment 4 Alex Thurgood 2019-02-25 11:02:03 UTC
Please don't reopen this again, it is indeed a duplicate of bug 42437.
As I said here, I agree that this should be implemented, but I am only a user (and volunteer QA bug triager), not a developer, volunteer or otherwise.

*** This bug has been marked as a duplicate of bug 42437 ***